View Issue Details

IDProjectCategoryView StatusLast Update
0003951Slicer4Core: Renderingpublic2018-03-31 01:24
ReporterkikinisAssigned Toaashish24 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0003951: VTK OpenGL2 Backend: GPU VR - Slower than CPU VR
Description

From Ron: the speed is not there yet at all. This is slower than CPU rendering on my machine

Slicer binaries with OpenGL backend available here: http://download.slicer.org

Tested on MacOSX using Slicer version based of VTK d733280 provided by installer from 2015-02-09:

Slicer-4.4.0-2015-02-09-macosx-amd64.dmg - http://slicer.kitware.com/midas3/item/176422

Slicer-4.4.0-2015-02-09-win-amd64.exe - http://slicer.kitware.com/midas3/item/176423

Tagsvtk-opengl2

Activities

jcfr

jcfr

2015-02-02 06:00

administrator   ~0012891

Last edited: 2015-02-02 06:01

@Ron: Could you provide the FPS for the following cases:

(1) Regular Slicer binary GPU VR
(2) Regular Slicer binary CPU VR
(3) OpenGL2 Slicer binary GPU VR
(4) OpenGL2 Slicer binary CPU VR

FPS can be displayed clicking on the "..." in the 3D view controller panel.

Could you also provide info about the GPU card installer on your workstation ?

2015-02-02 06:39

 

2015-02-25 12:03

 

2015-02-25 12:04

 

jcfr

jcfr

2015-02-25 12:05

administrator   ~0012939

Last edited: 2015-02-25 12:06

GPU card: NVIDIA GeForce GT 750M 2048 MB

VTKOpenGL2 backend (based of VTK d733280):

  • GPU rendering: 7 fps
  • CPU rendering: 17 fps
kikinis

kikinis

2015-02-25 12:17

developer   ~0012940

Last edited: 2017-10-13 17:22

View 3 revisions

I used one of the slicer sample data sets (chest, see under welcome module, sample data sets), one of the presets (chest-contrast-enhanced) and ROI clipping. I slightly modulated the preset using the shift transfer function in the VR module panel. This should be perfectly reproducible to the vkt team and allow them to measure any additional metrics that they need. I do not have access to the regular Slicer with the same SVN number and I already provided
Item 3 and 4 from note https://issues.slicer.org/view.php?id=3951#c12891. I think that it is critical that the VTK team try for themselves in order to see what I am referring to.

jcfr

jcfr

2015-06-01 12:38

administrator   ~0013112

VTK rendering experts are looking at profiling OpenGL code to see where the GPU mapper can be improved.

lassoan

lassoan

2017-09-26 10:44

developer   ~0015134

revisit this with OpenGL2 backend

jcfr

jcfr

2018-03-03 00:58

administrator   ~0015524

@kikinis Since the nightly build of Slicer now include the newer VTK OpenGL2 backend, is this still an issue ?

jcfr

jcfr

2018-03-31 01:24

administrator   ~0015633

Following last exchange with @kikinis , the GPU rendering is now behaving much better.

Issue History

Date Modified Username Field Change
2015-02-02 05:58 jcfr New Issue
2015-02-02 05:58 jcfr Status new => assigned
2015-02-02 05:58 jcfr Assigned To => jcfr
2015-02-02 05:58 jcfr Reporter jcfr => kikinis
2015-02-02 05:58 jcfr Description Updated
2015-02-02 06:00 jcfr Note Added: 0012891
2015-02-02 06:01 jcfr Note Edited: 0012891
2015-02-02 06:01 jcfr Note Edited: 0012891
2015-02-02 06:22 jcfr Assigned To jcfr => Ken Martin
2015-02-02 06:39 jcfr File Added: Screen Shot 2015-02-02 at 4.58.26 PM.png
2015-02-05 08:30 jcfr Assigned To Ken Martin => aashish24
2015-02-25 11:57 jcfr Severity minor => major
2015-02-25 11:57 jcfr Target Version => Slicer 4.5.0-1
2015-02-25 11:57 jcfr Description Updated
2015-02-25 12:00 jcfr File Added: VTK-OpenGL2-MacOSX-Slicer-2015-02-09_CPU.png
2015-02-25 12:00 jcfr File Deleted: VTK-OpenGL2-MacOSX-Slicer-2015-02-09_CPU.png
2015-02-25 12:03 jcfr File Added: Slicer-r23969_VTKOpenGL-backend_CPU-VR.png
2015-02-25 12:03 jcfr File Added: VTK-OpenGL2-MacOSX-Slicer-2015-02-09_CPU.png
2015-02-25 12:04 jcfr File Deleted: Slicer-r23969_VTKOpenGL-backend_CPU-VR.png
2015-02-25 12:04 jcfr File Added: VTK-OpenGL2-MacOSX-Slicer-2015-02-09_GPU.png
2015-02-25 12:05 jcfr Note Added: 0012939
2015-02-25 12:06 jcfr Note Edited: 0012939
2015-02-25 12:17 kikinis Note Added: 0012940
2015-06-01 12:38 jcfr Note Added: 0013112
2015-11-02 12:01 jcfr Target Version Slicer 4.5.0-1 => Slicer 4.6.0
2016-10-12 14:33 jcfr Target Version Slicer 4.6.0 => Slicer 4.7.0
2017-09-26 10:44 lassoan Target Version Slicer 4.7.0 => Slicer 4.9.0
2017-09-26 10:44 lassoan Note Added: 0015134
2017-10-13 17:21 jcfr Note Edited: 0012940 View Revisions
2017-10-13 17:22 jcfr Note Edited: 0012940 View Revisions
2018-03-02 16:05 jcfr Tag Attached: vtk-opengl2
2018-03-03 00:57 jcfr Summary VTKOpenGL2: GPU VR - Slower than CPU VR => VTK OpenGL2 Backend: GPU VR - Slower than CPU VR
2018-03-03 00:58 jcfr Status assigned => feedback
2018-03-03 00:58 jcfr Note Added: 0015524
2018-03-31 01:24 jcfr Status feedback => resolved
2018-03-31 01:24 jcfr Resolution open => fixed
2018-03-31 01:24 jcfr Fixed in Version => Slicer 4.9.0
2018-03-31 01:24 jcfr Note Added: 0015633