View Issue Details

IDProjectCategoryView StatusLast Update
0003957Slicer4Core: Renderingpublic2018-03-02 11:06
ReporterlassoanAssigned Toaashish24 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionSlicer 4.5.0-1Fixed in VersionSlicer 4.5.0-1 
Summary0003957: GPU volume rendering broken on HD Graphics 4400 on Windows 8 64-bit
Description

From Andras:

GPU volume rendering is broken (nothing or only the cube boundaries are displayed) with latest nightly Slicer on Intel HD Graphics 4400 on Windows 8 64-bit. See example images here:

https://onedrive.live.com/redir?resid=872AF7415C00BFB9!197128&authkey=!ABzUByFy8Ti1rB4&ithint=folder%2cpng

CPU volume rendering is OK on the same computer. GPU volume rendering is OK on a different computer with NVidia GPU.

Most probably the issue is caused by the big VR rework in VTK. I think some related fixes have been made in VTK recently (http://vtk.1045678.n5.nabble.com/22-new-failing-GPU-tests-on-OpenGL2-dashboard-tt5730140.html#a5730150), so it would be nice to merge them into Slicer’s VTK version and see if they solve the problem.

See http://slicer-devel.65872.n3.nabble.com/GPU-volume-rendering-is-broken-with-Intel-graphics-card-td4033463.html

TagsNo tags attached.

Activities

jcfr

jcfr

2015-02-10 18:35

administrator   ~0012905

Slicer Windows package built with OpenGL2 backend enabled fixes the problem.

2015-02-10 18:37

 

2015-02-10 18:37

 

Issue History

Date Modified Username Field Change
2015-02-10 18:34 jcfr New Issue
2015-02-10 18:34 jcfr Status new => assigned
2015-02-10 18:34 jcfr Assigned To => jcfr
2015-02-10 18:35 jcfr Reporter jcfr => lassoan
2015-02-10 18:35 jcfr Assigned To jcfr => aashish24
2015-02-10 18:35 jcfr Note Added: 0012905
2015-02-10 18:35 jcfr Status assigned => resolved
2015-02-10 18:35 jcfr Fixed in Version => Slicer 4.5.0-1
2015-02-10 18:35 jcfr Resolution open => fixed
2015-02-10 18:36 jcfr Target Version => Slicer 4.5.0-1
2015-02-10 18:37 jcfr File Added: Slicer-r23969_VTKOpenGL-backend_CPU-VR.png
2015-02-10 18:37 jcfr File Added: Slicer-r23969_VTKOpenGL-backend_GPU-VR.png
2018-03-02 11:06 jcfr Status resolved => closed