View Issue Details

IDProjectCategoryView StatusLast Update
0003958Slicer4Core: Packagingpublic2015-10-28 11:20
ReporterpohlAssigned Topohl 
PrioritynormalSeveritymajorReproducibilityunable to reproduce
Status assignedResolutionopen 
PlatformMACOSRon's MachineOS VersionN/A
Product VersionSlicer 4.4.0 
Target VersionFixed in Version 
Summary0003958: Import Error .. python2.7-lib-dynload/_tkinter.so 2) Library not loaded : /usr/X11/lib/libSM.6.dylib
Description

The EMSegmenter with Atlas does not work on the nightly build (1/23) installed on Ron's compute due to the error attached. In summary , Slicer is not able to find a specific lib in the usr directory of Ron :

Import Error .. python2.7-lib-dynload/_tkinter.so 2) Library not loaded : /usr/X11/lib/libSM.6.dylib

When I create a package on my mac machine (Yosemity) and install it on my machine then I do not have this issue as it ofcourse uses the same X11 environment !This is also only an issue on macs. I installed the nightly builds on my linux and windows platform . Everything works fine

Steps To Reproduce

1) Install a nighlty build on a mac
2) Start Slicer
3) Download the MR Sample Head
4) Go to EMSegmenter with Atlas
5) Press simple
6) select the MR Sample Head
7) Press Run or Segment

TagsNo tags attached.

Activities

2015-02-12 07:41

 

pohl

pohl

2015-02-15 06:58

developer   ~0012911

JC: Since with MacOSX >= 10.8 [1], X11 libraries are not shipped anymore with the operating system, users should install XQuartz. See [2]

Ron installed XQuarz and confirmed that this resolves the bug.

[1] http://www.macrumors.com/2012/02/17/apple-removes-x11-in-os-x-mountain-lion-shifts-support-to-open-source-xquartz/
[2] http://xquartz.macosforge.org/landing/

pohl

pohl

2015-02-15 06:58

developer   ~0012912

JC: If we would like to include the XQuartz libraries in the Slicer package, we should:

(1) on the factory, install X11 libraries in a non system location
(2) update the Slicer build system so that these same libraries are used to configure/link/build tcl, tkinter, ...
(3) ensure they are packaged by fixing the SlicerCPackBundleFixup script

jcfr

jcfr

2015-10-23 23:01

administrator   ~0013419

Please let me know if this still an issue when using the latest package. In the mean time, I am un-targeting the issue.

pohl

pohl

2015-10-28 10:37

developer   ~0013446

I think we just need to add a note to the documentation of Slicer that mac users need to install XQuartz - correct ?

jcfr

jcfr

2015-10-28 10:58

administrator   ~0013447

Since X11 is required only for tcl/tk expected by EMSegment. You could indeed:

(1) Add documentation in the EMSegment wiki page

(2) Add a runtime check in the init function of the EMSegment modules that would report a clear message

pohl

pohl

2015-10-28 11:14

developer   ~0013448

sounds good

jcfr

jcfr

2015-10-28 11:20

administrator   ~0013449

Great. Re-assigning the issue to you then.

Issue History

Date Modified Username Field Change
2015-02-12 07:41 pohl New Issue
2015-02-12 07:41 pohl Status new => assigned
2015-02-12 07:41 pohl Assigned To => jcfr
2015-02-12 07:41 pohl File Added: Screen Shot 2015-02-04 at 6.17.15 AM.png
2015-02-12 07:56 jcfr Status assigned => acknowledged
2015-02-12 07:56 jcfr Target Version Slicer 4.4.1 => Slicer 4.5.0-1
2015-02-15 06:58 pohl Note Added: 0012911
2015-02-15 06:58 pohl Note Added: 0012912
2015-10-23 23:00 jcfr Target Version Slicer 4.5.0-1 =>
2015-10-23 23:01 jcfr Note Added: 0013419
2015-10-28 10:37 pohl Note Added: 0013446
2015-10-28 10:58 jcfr Note Added: 0013447
2015-10-28 11:14 pohl Note Added: 0013448
2015-10-28 11:19 jcfr Status acknowledged => assigned
2015-10-28 11:19 jcfr Assigned To jcfr => pohl
2015-10-28 11:20 jcfr Note Added: 0013449