View Issue Details

IDProjectCategoryView StatusLast Update
0003985Slicer4Module VolumeRenderingpublic2017-06-11 21:26
ReporterAlvaroCuevasAssigned Tofinetjul 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product VersionSlicer 4.4.0 
Target VersionFixed in Version 
Summary0003985: On VolumeRendering specified data program crashes
Description

While VolumeRendering the specified DICOM data available on
http://mecanica-usach.mine.nu/media/dicom.zip
the program hard crashes and if enabling debugging or verbose output the results are the same and no aditional information is supplied, this was tested using the nightly build (2015-04-09) and the stable version.
In the mentioned nightly build the file gave another error corresponding to a miss imported python module, after fixing the code in lib/Slicer-4.4/qt-scripted-modules/MultiVolumImporterPlugin.py by removing the bad reference to DICOMLib the error we had on the stable build came back, but before making the change the data was visible but highly distorted and a VolumeRendering could be done succesfully but because the data was highly distorted no useful results could be obtained.

Additional Information

issues were found with 1 of the series. Please use caution.
MultiVolumeImportPlugin::examine
DICOMMultiVolumePlugin found 1 multivolumes!
MultiVolumeImportPlugin:examineMultiseries
DICOMMultiVolumePlugin found 0 multivolumes!
Threshold: 0 6400.93
ctkDoubleSlider::setSingleStep( 100 ) is outside of valid bounds.
Warning: In /home/kitware/Dashboards/Package/Slicer-440-package/VTKv6/Rendering/Volume/vtkFixedPointVolumeRayCastMapper.cxx, line 1500
vtkFixedPointVolumeRayCastMapper (0x66ced80): Number of threads 8 is > 1. This class does not produce repeatable results when the number of threads exceeds 1.

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

Bad index - must be between 0 and 3

error: [/home/alvaro/Escritorio/Slicer/Slicer-4.4.0-linux-amd64/./bin/SlicerApp-real] exit abnormally - Report the problem.

TagsNo tags attached.

Activities

lassoan

lassoan

2017-06-11 21:26

developer   ~0014767

It is not reproducible anymore in Slicer 4.7.0-2017-06-02 (Windows 10). Both DICOM import and volume rendering work beautifully.

Issue History

Date Modified Username Field Change
2015-04-13 15:34 AlvaroCuevas New Issue
2015-04-13 15:34 AlvaroCuevas Status new => assigned
2015-04-13 15:34 AlvaroCuevas Assigned To => finetjul
2017-06-11 21:26 lassoan Status assigned => resolved
2017-06-11 21:26 lassoan Resolution open => unable to reproduce
2017-06-11 21:26 lassoan Note Added: 0014767