View Issue Details

IDProjectCategoryView StatusLast Update
0003988Slicer4Core: Base Codepublic2016-02-26 14:09
ReporterfbudinAssigned Toalexy 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003988: User can only display diffusion tensor with glyphs if the scalar mode that is selected if colorOrientation
Description

It can be convenient sometimes to look at the glyphs when visualizing a DTI and to overlay the glyphs to the Fractional Anisotropy or the Mean Diffusivity.
The Volume module in Slicer allows the user to select the scalar mode that is displayed when a diffusion tensor image is selected (ColorOrientation, FractionalAnisotropy,Trace,...). However, the glyphs representing the tensors can only be displayed in the 2D views if the selected scalar mode is "ColorOrientation". The only way of visualizing the glyphs with the FA or the MD is to compute it, select the DTI as the foreground (or background) image, select the FA/MD as the background (or foreground) image, and then move the slider that selects the transparency of each layer such that the FA/MD image is visible. This way, the glyphs are visible on top of the FA/MD, and not only on top of the ColorFA. This workaround is not very complicated, but one may wonder why it is not allowed to directly display the glyphs on top of the FA/MD that is directly visible from the tensor image by changing the scalar mode to the appropriate value.

TagsNo tags attached.

Relationships

related to 0003702 resolvedalexy Can't display glyphs overlaid on FA map 

Activities

alexy

alexy

2016-02-26 14:09

developer   ~0013826

Enabled glyphs display for all scalar components on slices. The glyphs visibility was disabled because of crashes described in
http://na-mic.org/Mantis/view.php?id=3323 [^]
which have been fixed.

Issue History

Date Modified Username Field Change
2015-04-15 08:08 fbudin New Issue
2015-04-15 08:08 fbudin Status new => assigned
2015-04-15 08:08 fbudin Assigned To => jcfr
2016-01-05 14:56 lauren Relationship added related to 0003702
2016-02-26 14:09 alexy Note Added: 0013826
2016-02-26 14:09 alexy Assigned To jcfr => alexy
2016-02-26 14:09 alexy Status assigned => resolved
2016-02-26 14:09 alexy Resolution open => fixed