View Issue Details

IDProjectCategoryView StatusLast Update
0004001Slicer4Module DICOMpublic2018-05-30 00:40
ReporterkirbyjuAssigned Tomehrtash 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSlicer 4.4.0 
Target VersionFixed in VersionSlicer 4.8.1 
Summary0004001: DICOM import failure due to incorrect database directory
Description

I was unable to import some DICOM files in the 6/10 nightly build on Windows 7. Eventually I realized it was because Slicer defaulted to storing the database somewhere in my c:\Program Files\ directory which is read-only on my computer unless I'm logged in as an administrator.

Rather than giving an error with an explanation the import dialog would just report that 0 images were imported. It would be better if it gave some kind of error informing the user that a permissions error was preventing it from creating the necessary database file(s). Once I picked a directory that didn’t require admin rights the import worked fine.

TagsNo tags attached.

Activities

pieper

pieper

2015-06-14 15:00

administrator   ~0013126

What should be happening is that the first time you run Slicer's DICOM module it puts up a dialog letting you know where it will try to create the database - did this happen do you recall? I don't know if it checks the validity of the directory at that time but I agree it should be checking that.

kirbyju

kirbyju

2015-06-15 06:01

reporter   ~0013128

No, I don't think it did.

pieper

pieper

2015-06-15 11:08

administrator   ~0013129

Alireza can you test this out and look for a workaround? The code linked below should be getting called if the database cannot be opened.

https://github.com/Slicer/Slicer/blob/master/Modules/Scripted/DICOMLib/DICOMWidgets.py#L379-L407

lassoan

lassoan

2018-05-30 00:40

developer   ~0015810

Automatic folder selection is more robust now.

Issue History

Date Modified Username Field Change
2015-06-11 13:03 kirbyju New Issue
2015-06-11 13:03 kirbyju Status new => assigned
2015-06-11 13:03 kirbyju Assigned To => pieper
2015-06-14 15:00 pieper Note Added: 0013126
2015-06-15 06:01 kirbyju Note Added: 0013128
2015-06-15 11:04 pieper Assigned To pieper => mehrtash
2015-06-15 11:08 pieper Note Added: 0013129
2015-06-15 11:08 pieper Status assigned => acknowledged
2017-06-15 02:09 lassoan Summary import failure in win7 using 6/10 nightly => DICOM import failure due to incorrect database directory
2018-05-30 00:40 lassoan Status acknowledged => resolved
2018-05-30 00:40 lassoan Resolution open => fixed
2018-05-30 00:40 lassoan Fixed in Version => Slicer 4.8.1
2018-05-30 00:40 lassoan Note Added: 0015810