View Issue Details

IDProjectCategoryView StatusLast Update
0004094Slicer4Core: Performancepublic2016-02-22 11:09
ReporterlassoanAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionopen 
Product VersionSlicer 4.5.0-1 
Target VersionFixed in Version 
Summary0004094: Data Probe slows down Slicer if mouse is moving in the slice viewers
Description

From: slicer-devel-bounces@bwh.harvard.edu [mailto:slicer-devel-bounces@bwh.harvard.edu] On Behalf Of criskross
Sent: November 24, 2015 2:37 PM
To: SPL Slicer Devel <slicer-devel@bwh.harvard.edu>
Subject: [slicer-devel] Slicer enormous performance loss caused by Data Probe

Hi developers,

I noticed, that Slicer looses a lot of performance when the Data Probe panel is visible and moving the cursor during processing in some viewer.

To reproduce this:

  1. Open Performance Tests
  2. Get Sample Data
  3. Reslicing (with Data Probe Panel open WITHOUT moving cursor in viewer) 4. Reslicing (with Data Probe Panel open AND moving cursor in viewer)
TagsNo tags attached.

Activities

lassoan

lassoan

2015-11-26 12:06

developer   ~0013646

I couldn't reproduce any significant performance decrease on Windows.

Could you please check if the problem still exists if you change in .../qt-scripted-modules/DataProbe.py

From this:
...
def processEvent(self,observee,event):

TODO: use a timer to delay calculation and compress events

insideView = False
ras = [0.0,0.0,0.0]
...

To this:
...
def processEvent(self,observee,event):
return

TODO: use a timer to delay calculation and compress events

insideView = False
ras = [0.0,0.0,0.0]

...

Andras

lassoan

lassoan

2015-11-26 12:06

developer   ~0013647

-----Original Message-----
From: slicer-devel-bounces@bwh.harvard.edu [mailto:slicer-devel-bounces@bwh.harvard.edu] On Behalf Of criskross
Sent: Tuesday, November 24, 2015 11:36 PM
To: SPL Slicer Devel <slicer-devel@bwh.harvard.edu>
Subject: Re: [slicer-devel] Slicer enormous performance loss caused by Data Probe

Hi Andras,

the problem doesn't exist when I change the code like you said.

pieper

pieper

2016-01-12 14:31

administrator   ~0013716

This issue has been confirmed to be related to Mac OS 10.11 (El Capitan) and does not occur on 10.10 (Yosemite)

pieper

pieper

2016-01-12 14:49

administrator   ~0013717

Possibly related issue: https://bugreports.qt.io/browse/QTBUG-47354

Issue History

Date Modified Username Field Change
2015-11-26 12:06 lassoan New Issue
2015-11-26 12:06 lassoan Status new => assigned
2015-11-26 12:06 lassoan Assigned To => jcfr
2015-11-26 12:06 lassoan Note Added: 0013646
2015-11-26 12:06 lassoan Note Added: 0013647
2016-01-12 14:31 pieper Note Added: 0013716
2016-01-12 14:49 pieper Note Added: 0013717