View Issue Details

IDProjectCategoryView StatusLast Update
0004118Slicer4Core: Documentation and Wikipublic2016-06-01 16:53
ReporterfedorovAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0004118: Spaces inserted into extensions/modules names
Description

There are extra spaces that are introduced into the names of extensions and modules. Are these inserted automatically? It is not clear why this is done. I would prefer not to see those spaces to keep the names consistent between the Slicer application, documentation pages and names on the modules list.

TagsNo tags attached.

Activities

fedorov

fedorov

2016-01-04 09:58

developer  

johan.andruejol

johan.andruejol

2016-06-01 13:54

manager  

4118.PNG (Attachment missing)
johan.andruejol

johan.andruejol

2016-06-01 13:55

manager   ~0013916

As of June 1st 2016, the users documentation on the wiki doesn't
split the names. See attached screenshot.

fedorov

fedorov

2016-06-01 13:59

developer   ~0013917

It does.

As an example, look for "mp Review". The correct name of the extension is mpReview.

fedorov

fedorov

2016-06-01 14:03

developer  

Screen Shot 2016-06-01 at 2.02.06 PM.png (Attachment missing)
fedorov

fedorov

2016-06-01 14:14

developer   ~0013918

it seems like the page is rendering differently on your side from what I see. I am running in a Chrome incognito view, and I still see spaces as in the screenshot I attached, so I am not sure what I might be doing wrong.

fedorov

fedorov

2016-06-01 14:14

developer   ~0013919

this is the page I am looking at: http://wiki.slicer.org/slicerWiki/index.php/Documentation/Nightly

johan.andruejol

johan.andruejol

2016-06-01 14:19

manager   ~0013920

I was looking at https://www.slicer.org/slicerWiki/index.php/Documentation/4.5.

You're right, on the nightly page I see the space too. Good catch ! I will re-open the issue.

jcfr

jcfr

2016-06-01 16:18

administrator   ~0013926

The problem is most likely with this function: https://github.com/Slicer/slicer-wiki-scripts/blob/ee4b87b2beaed0d091a227ff5d1588d3fd7f38e1/slicer_wiki_extension_module_listing.py#L168-L172

Note that page for Slicer 4.5 have manually been fixed: http://wiki.slicer.org/slicerWiki/index.php?title=Documentation%2F4.5%2FModuleExtensionListing&type=revision&diff=44519&oldid=43882

fedorov

fedorov

2016-06-01 16:20

developer   ~0013927

The problem is most likely with this function

@jcfr: I don't understand why we need to convert camel-case to space delimited at all.

jcfr

jcfr

2016-06-01 16:43

administrator   ~0013928

@andrey: Two years ago, look like a good idea.

The intent was to:

With the time, it turns out to be a bad decision, extension are referenced by name and there are no title explicitly provided anywhere.

Let's display the original extension name.

We should have some example of updated reset on a separate test wiki page soon.

fedorov

fedorov

2016-06-01 16:53

developer   ~0013929

Makes sense. "It’s Difficult to Make Predictions, Especially About the Future" :)

On the same token, it might have been a good idea to have a short/abbreviated name for the extension, and a longer, human-readable (or just de-camel-cased, but defined by the owner of the extension) as well...

Issue History

Date Modified Username Field Change
2016-01-04 09:58 fedorov New Issue
2016-01-04 09:58 fedorov Status new => assigned
2016-01-04 09:58 fedorov Assigned To => jcfr
2016-01-04 09:58 fedorov File Added: Screenshot at Jan 04 09-56-49.png
2016-06-01 13:54 johan.andruejol File Added: 4118.PNG
2016-06-01 13:55 johan.andruejol Note Added: 0013916
2016-06-01 13:55 johan.andruejol Status assigned => resolved
2016-06-01 13:55 johan.andruejol Resolution open => no change required
2016-06-01 13:59 fedorov Note Added: 0013917
2016-06-01 14:00 fedorov Status resolved => feedback
2016-06-01 14:00 fedorov Resolution no change required => reopened
2016-06-01 14:03 fedorov File Added: Screen Shot 2016-06-01 at 2.02.06 PM.png
2016-06-01 14:14 fedorov Note Added: 0013918
2016-06-01 14:14 fedorov Status feedback => assigned
2016-06-01 14:14 fedorov Note Added: 0013919
2016-06-01 14:19 johan.andruejol Note Added: 0013920
2016-06-01 16:18 jcfr Note Added: 0013926
2016-06-01 16:20 fedorov Note Added: 0013927
2016-06-01 16:43 jcfr Note Added: 0013928
2016-06-01 16:53 fedorov Note Added: 0013929
2016-06-20 14:15 jcfr Category Core: Documentation & Wiki => Core: Documentation and Wiki