View Issue Details

IDProjectCategoryView StatusLast Update
0004149Slicer4Core: MRMLpublic2017-06-15 02:29
ReportercriskrossAssigned Toalexy 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0004149: Setting crosshairNode programmatically does not work properly
Description

The following code displays the basic crosshair instead of the small basic one:

crosshairNode = slicer.mrmlScene.GetNthNodeByClass(0,
'vtkMRMLCrosshairNode')
crosshairNode.SetCrosshairMode(slicer.vtkMRMLCrosshairNode.ShowSmallBasic)

The crosshair is shown, but in its basic appearance (not small).

It works, when I execute the following code:

crosshairNode = slicer.mrmlScene.GetNthNodeByClass(0,
'vtkMRMLCrosshairNode')
crosshairNode.SetCrosshairMode(slicer.vtkMRMLCrosshairNode.ShowSmallBasic)
crosshairNode.SetCrosshairMode(slicer.vtkMRMLCrosshairNode.ShowSmallBasic)

Steps To Reproduce
  1. restart Slicer
  2. open python console
  3. run:
    crosshairNode = slicer.mrmlScene.GetNthNodeByClass(0,
    'vtkMRMLCrosshairNode')
    crosshairNode.SetCrosshairMode(slicer.vtkMRMLCrosshairNode.ShowSmallBasic)
  4. small basic crosshair should be activated, but instead the basic crosshair is activated
TagsNo tags attached.

Activities

lassoan

lassoan

2017-06-15 02:29

developer   ~0014857

The problem is not reproducible anymore in Slicer 4.7.0-2017-06-02 (Windows 10)

Issue History

Date Modified Username Field Change
2016-02-08 17:30 criskross New Issue
2016-02-08 17:30 criskross Status new => assigned
2016-02-08 17:30 criskross Assigned To => alexy
2017-06-15 02:29 lassoan Status assigned => resolved
2017-06-15 02:29 lassoan Resolution open => unable to reproduce
2017-06-15 02:29 lassoan Note Added: 0014857