View Issue Details

IDProjectCategoryView StatusLast Update
0004156Slicer4Core: GUIpublic2018-05-08 15:13
ReporterpinterAssigned Tojcfr 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionSlicer 4.5.0-1 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.6.0 
Summary0004156: Encode illegal characters in file names and paths
Description

It would be needed to "sanitize" file names before saving by replacing a list of "bad" characters with underscores.

Additional Information

See description of http://www.na-mic.org/Bug/view.php?id=3991

TagsNo tags attached.

Relationships

related to 0004314 confirmedpieper When a non-ASCII character exists in the path a DICOM cannot be opened if only links are imported 
related to 0004523 new Save dialog: Trim spaces when node name contain space at the end or begining 

Activities

jcfr

jcfr

2016-10-12 03:25

administrator   ~0014162

Resolving this issue. It not reproducible with Slicer >= r25427

pinter

pinter

2016-10-12 14:26

developer   ~0014180

Still problematic with certain characters in the path.

It works with 'é' but not with '?' for example

pinter

pinter

2016-10-12 14:28

developer   ~0014181

Yeah the question mark is supposed to be the double accents on an o
https://en.wikipedia.org/wiki/Double_acute_accent

pinter

pinter

2016-10-12 14:31

developer   ~0014183

Not sure to what extent we are worried about this issue. If the goal is to support all latin alphabet languages, then we're not there yet. On the other hand we can pick certain languages, but then there will be always people who cannot read files because of this.

jcfr

jcfr

2018-03-22 01:41

administrator   ~0015595

Closing. This was addressed by @lassoan in http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=25389



jcfr

jcfr

2018-03-22 01:45

administrator   ~0015596

Also, accent are replaced by ? in the node name, and spaces in the file name.

An optimization could be trim the extra space at the end of the filename.



4156-accent-sanitized.png (33,997 bytes)
4156-accent-sanitized.png (33,997 bytes)
pinter

pinter

2018-03-22 08:29

developer   ~0015608

Last edited: 2018-03-22 08:30

View 2 revisions

Again, a question that was left unanswered in the rush of closing tickets. Let's at least settle on a decision, because if we just close partially addressed tickets for the sake of reducing their number, there's a good chance a second ticket will pop up about the second half of the problem very soon.

jcfr

jcfr

2018-05-08 15:13

administrator   ~0015703

@cpinter Thanks for your comment. Would you mind creating a more specific issue outlining the remaining issue ?

Issue History

Date Modified Username Field Change
2016-02-23 10:41 pinter New Issue
2016-10-12 03:25 jcfr Note Added: 0014162
2016-10-12 03:25 jcfr Status new => resolved
2016-10-12 03:25 jcfr Fixed in Version => Slicer 4.6.0
2016-10-12 03:25 jcfr Resolution open => fixed
2016-10-12 03:25 jcfr Assigned To => jcfr
2016-10-12 14:26 pinter Note Added: 0014180
2016-10-12 14:26 pinter Status resolved => confirmed
2016-10-12 14:28 pinter Note Added: 0014181
2016-10-12 14:31 pinter Note Added: 0014183
2016-10-13 01:22 jcfr Target Version Slicer 4.6.0 => Slicer 4.7.0
2016-12-09 10:56 pinter Relationship added related to 0004314
2017-09-27 12:21 lassoan Target Version Slicer 4.7.0 => Slicer 4.9.0
2018-03-22 01:41 jcfr File Added: 4156-filename-sanitized.png
2018-03-22 01:41 jcfr Note Added: 0015595
2018-03-22 01:42 jcfr Status confirmed => resolved
2018-03-22 01:45 jcfr File Added: 4156-accent-sanitized.png
2018-03-22 01:45 jcfr Note Added: 0015596
2018-03-22 01:46 jcfr Relationship added related to 0004523
2018-03-22 08:29 pinter Note Added: 0015608
2018-03-22 08:30 pinter Note Edited: 0015608 View Revisions
2018-05-08 15:13 jcfr Note Added: 0015703