View Issue Details

IDProjectCategoryView StatusLast Update
0004164Slicer4Module VolumeRenderingpublic2017-08-14 09:36
ReportermatrimcauthonAssigned Tofinetjul 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformOSXOSOSXOS Version10.10.5
Product VersionSlicer 4.5.0-1 
Target VersionFixed in VersionSlicer 4.7.0 
Summary0004164: Volume rendering crashes every time volume input is switched
Description

I am using the 2016-03-18 nightly. Everytime I switch from a volume i rendered to a masked version of it slicer completely crashes.

Steps To Reproduce

1) Volume render with CPU a volume
2) switch input to another volume
3) crash

Additional Information

[DEBUG][Qt] 24.03.2016 16:33:40 [] (unknown:0) - Session start time .......: 2016-03-24 16:33:40
[DEBUG][Qt] 24.03.2016 16:33:40 [] (unknown:0) - Slicer version ...........: 4.5.0-2016-03-18 (revision 24973) macosx-amd64 - installed
[DEBUG][Qt] 24.03.2016 16:33:40 [] (unknown:0) - Operating system .........: Mac OS X / 10.10.5 / 14F1605 - 64-bit
[DEBUG][Qt] 24.03.2016 16:33:40 [] (unknown:0) - Memory ...................: 131072 MB physical, 0 MB virtual
[DEBUG][Qt] 24.03.2016 16:33:40 [] (unknown:0) - CPU ......................: GenuineIntel 2.700 MHz, 12 cores
[DEBUG][Qt] 24.03.2016 16:33:40 [] (unknown:0) - Developer mode enabled ...: no
[DEBUG][Qt] 24.03.2016 16:33:40 [] (unknown:0) - Prefer executable CLI ....: yes
[DEBUG][Qt] 24.03.2016 16:33:40 [] (unknown:0) - Additional module paths ..: (none)
[CRITICAL][Qt] 24.03.2016 16:33:43 [] (unknown:0) - Error(s):
Cannot load library /Applications/slicer_3-21-2016/Slicer.app/Contents/lib/Slicer-4.5/cli-modules/libPerformMetricTestLib.dylib: (dlopen(/Applications/slicer_3-21-2016/Slicer.app/Contents/lib/Slicer-4.5/cli-modules/libPerformMetricTestLib.dylib, 5): Library not loaded: /Users/kitware/Dashboards/Nightly/Slicer-0-build/ITKv4-build/lib/libITKIOBMP-4.10.1.dylib
Referenced from: /Applications/slicer_3-21-2016/Slicer.app/Contents/lib/Slicer-4.5/cli-modules/libPerformMetricTestLib.dylib
Reason: image not found)
[CRITICAL][Qt] 24.03.2016 16:33:44 [] (unknown:0) - Error(s):
Cannot load library /Applications/slicer_3-21-2016/Slicer.app/Contents/lib/Slicer-4.5/cli-modules/libVBRAINSDemonWarpLib.dylib: (dlopen(/Applications/slicer_3-21-2016/Slicer.app/Contents/lib/Slicer-4.5/cli-modules/libVBRAINSDemonWarpLib.dylib, 5): Library not loaded: /Users/kitware/Dashboards/Nightly/Slicer-0-build/ITKv4-build/lib/libITKIOBMP-4.10.1.dylib
Referenced from: /Applications/slicer_3-21-2016/Slicer.app/Contents/lib/Slicer-4.5/cli-modules/libVBRAINSDemonWarpLib.dylib
Reason: image not found)
[DEBUG][Qt] 24.03.2016 16:33:44 [] (unknown:0) - Number of registered modules: 143
[DEBUG][Qt] 24.03.2016 16:33:49 [] (unknown:0) - Number of instantiated modules: 143
[WARNING][Qt] 24.03.2016 16:33:50 [] (unknown:0) - When loading module "CLIEventTest" , the dependency "CLI4Test" failed to be loaded.
[INFO][Stream] 24.03.2016 16:33:50 [] (unknown:0) - Initializing terminology mapping for map file /Applications/slicer_3-21-2016/Slicer.app/Contents/share/Slicer-4.5/ColorFiles/Terminology//GenericAnatomyColors-SNOMED.csv
[INFO][Stream] 24.03.2016 16:33:50 [] (unknown:0) - 288 terms were read for Slicer LUT GenericAnatomyColors
[WARNING][Qt] 24.03.2016 16:33:50 [] (unknown:0) - When loading module "TwoCLIsInARowTest" , the dependency "CLI4Test" failed to be loaded.
[WARNING][Qt] 24.03.2016 16:33:50 [] (unknown:0) - When loading module "TwoCLIsInParallelTest" , the dependency "CLI4Test" failed to be loaded.
[DEBUG][Qt] 24.03.2016 16:33:50 [] (unknown:0) - Number of loaded modules: 140
[DEBUG][Qt] 24.03.2016 16:33:50 [] (unknown:0) - Switch to module: "Welcome"
[CRITICAL][FD] 24.03.2016 16:34:02 [] (unknown:0) - 2016-03-24 16:34:02.692 Slicer[29274:1879125] modalSession has been exited prematurely - check for a reentrant call to endModalSession:
[CRITICAL][FD] 24.03.2016 16:34:03 [] (unknown:0) - 2016-03-24 16:34:03.542 Slicer[29274:1879125] modalSession has been exited prematurely - check for a reentrant call to endModalSession:
[INFO][VTK] 24.03.2016 16:34:11 [vtkMRMLVolumeArchetypeStorageNode (0x13edbfcf0)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkMRMLVolumeArchetypeStorageNode.cxx:455) - Loaded volume from file: /Volumes/Sammy_Tank/CT_Scan_Place/Foam/Tiff_Stacks/Sn 5 tiff stack raw/Slicer_vs/canitbesaved/Original_Tiff_Stack.tif. Dimensions: 1512x1512x1593. Number of components: 1. Pixel type: unsigned short.
[WARNING][VTK] 24.03.2016 16:34:11 [vtkObserverManager (0x1480ac1f0)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkObserverManager.cxx:131) - The same object is already observed with the same priority. The observation is kept as is.
[INFO][VTK] 24.03.2016 16:34:44 [vtkMRMLVolumeArchetypeStorageNode (0x1480f8450)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkMRMLVolumeArchetypeStorageNode.cxx:455) - Loaded volume from file: /Volumes/Sammy_Tank/CT_Scan_Place/Foam/Tiff_Stacks/Sn 5 tiff stack raw/Slicer_vs/canitbesaved/Trimmed_Tiff_Stack_Vol.nrrd. Dimensions: 1311x1316x1351. Number of components: 1. Pixel type: unsigned short.
[WARNING][VTK] 24.03.2016 16:34:44 [vtkObserverManager (0x1480f9d60)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkObserverManager.cxx:131) - The same object is already observed with the same priority. The observation is kept as is.
[INFO][VTK] 24.03.2016 16:35:01 [vtkMRMLVolumeArchetypeStorageNode (0x1481068f0)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkMRMLVolumeArchetypeStorageNode.cxx:455) - Loaded volume from file: /Volumes/Sammy_Tank/CT_Scan_Place/Foam/Tiff_Stacks/Sn 5 tiff stack raw/Slicer_vs/canitbesaved/Foam_Component_Labels.nrrd. Dimensions: 1311x1316x1351. Number of components: 1. Pixel type: short.
[INFO][VTK] 24.03.2016 16:35:17 [vtkMRMLVolumeArchetypeStorageNode (0x1481070a0)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkMRMLVolumeArchetypeStorageNode.cxx:455) - Loaded volume from file: /Volumes/Sammy_Tank/CT_Scan_Place/Foam/Tiff_Stacks/Sn 5 tiff stack raw/Slicer_vs/canitbesaved/Foam_Occlusions.nrrd. Dimensions: 1311x1316x1351. Number of components: 1. Pixel type: short.
[INFO][VTK] 24.03.2016 16:35:32 [vtkMRMLVolumeArchetypeStorageNode (0x148107650)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkMRMLVolumeArchetypeStorageNode.cxx:455) - Loaded volume from file: /Volumes/Sammy_Tank/CT_Scan_Place/Foam/Tiff_Stacks/Sn 5 tiff stack raw/Slicer_vs/canitbesaved/Foam_Cells.nrrd. Dimensions: 1311x1316x1351. Number of components: 1. Pixel type: short.
[INFO][VTK] 24.03.2016 16:36:12 [vtkMRMLVolumeArchetypeStorageNode (0x1481091b0)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkMRMLVolumeArchetypeStorageNode.cxx:455) - Loaded volume from file: /Volumes/Sammy_Tank/CT_Scan_Place/Foam/Tiff_Stacks/Sn 5 tiff stack raw/Slicer_vs/canitbesaved/Foam_Only_Vol.nrrd. Dimensions: 1311x1316x1351. Number of components: 1. Pixel type: unsigned short.
[WARNING][VTK] 24.03.2016 16:36:12 [vtkMRMLVolumeRenderingDisplayableManager (0x13c393d20)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Modules/Loadable/VolumeRendering/MRMLDM/vtkMRMLVolumeRenderingDisplayableManager.cxx:1082) - No volume property node set
[DEBUG][Qt] 24.03.2016 16:36:12 [] (unknown:0) - "MRML Scene" Reader has successfully read the file "/Volumes/Sammy_Tank/CT_Scan_Place/Foam/Tiff_Stacks/Sn 5 tiff stack raw/Slicer_vs/canitbesaved/Base_2D_View.mrml"
[CRITICAL][FD] 24.03.2016 16:38:00 [] (unknown:0) - 2016-03-24 16:38:00.503 Slicer[29274:1879125] modalSession has been exited prematurely - check for a reentrant call to endModalSession:
[DEBUG][Qt] 24.03.2016 16:38:05 [] (unknown:0) - Switch to module: "VolumeRendering"
[WARNING][Qt] 24.03.2016 16:38:05 [] (unknown:0) - ctkDoubleSlider::setSingleStep( 1000 ) is outside of valid bounds.
[WARNING][VTK] 24.03.2016 16:38:05 [vtkObserverManager (0x1480f9d60)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkObserverManager.cxx:131) - The same object is already observed with the same priority. The observation is kept as is.
[WARNING][VTK] 24.03.2016 16:38:10 [vtkObserverManager (0x11b58bcf0)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkObserverManager.cxx:131) - The same object is already observed with the same priority. The observation is kept as is.
[WARNING][VTK] 24.03.2016 16:38:10 [vtkObserverManager (0x11b58bcf0)] (/Users/kitware/Dashboards/Nightly/Slicer-0/Libs/MRML/Core/vtkObserverManager.cxx:131) - The same object is already observed with the same priority. The observation is kept as is.

TagsNo tags attached.

Activities

jcfr

jcfr

2017-08-14 09:36

administrator   ~0015047

Hi,

This is most likely fixed in the current nightly build.

If this is still a problem, could you create a new issue and upload anonymized dataset allowing to reproduce the problem.

Thanks

Issue History

Date Modified Username Field Change
2016-03-24 18:46 matrimcauthon New Issue
2016-03-24 18:46 matrimcauthon Status new => assigned
2016-03-24 18:46 matrimcauthon Assigned To => finetjul
2017-08-14 09:36 jcfr Status assigned => resolved
2017-08-14 09:36 jcfr Resolution open => unable to reproduce
2017-08-14 09:36 jcfr Fixed in Version => Slicer 4.7.0
2017-08-14 09:36 jcfr Note Added: 0015047