View Issue Details

IDProjectCategoryView StatusLast Update
0004173Slicer4Module OpenIGTLinkIFpublic2017-06-12 23:13
Reporterleochan2009Assigned Totokuda 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformWindowsOSWindowsOS VersionWindows 7
Product Version 
Target VersionFixed in Version 
Summary0004173: igtlMultiThreaderTest1 and igtlMultiThreaderTest2 failed in Windows 7, due to Multi-threader stack pointer corrupt
Description

The following two lines corrupted for igtlMultiThreaderTest1 and igtlMultiThreaderTest2 respectively.

line 302: this->m_SingleMethod((void )(&this->m_ThreadInfoArray[0]));
and
line 492: (this->m_MultipleMethod[0])((void
)(&this->m_ThreadInfoArray[0]) );

The error message is:
"Run-Time Check Failure #0 - The value of ESP was not properly saved across a function call. This is usually a result of calling a function declared with one calling convention with a function pointer declared with a different calling convention."

The c++ compiler used is Visual Studio 2005, which is not the recommanded Visual studio 2008. So it is not sure if the bug is reproducible under visual studio 2008.

Additional Information

This problem can be solved by setting the compiler option from /RTC1 to /RTCu.

TagsNo tags attached.

Activities

lassoan

lassoan

2017-06-12 23:13

developer   ~0014790

These tests pass on Windows with latest nightly Slicer version using VS2013, without disabling run-time checks (keeping /RTC1), in both Debug and Release mode.

Issue History

Date Modified Username Field Change
2016-04-19 21:15 leochan2009 New Issue
2016-04-19 21:15 leochan2009 Status new => assigned
2016-04-19 21:15 leochan2009 Assigned To => tokuda
2017-06-12 23:13 lassoan Status assigned => resolved
2017-06-12 23:13 lassoan Resolution open => unable to reproduce
2017-06-12 23:13 lassoan Note Added: 0014790