View Issue Details

IDProjectCategoryView StatusLast Update
0004203Slicer4Extension: (Any extensions)public2016-06-03 15:11
ReporterSean Doyle Assigned Tofedorov  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformMacOSOSXOS Version10.11.5
Product VersionSlicer 4.5.0-1 
Target VersionFixed in Version 
Summary0004203: Can't export DICOM SEG object with nightly build from 2016/06/02
Description

Trying to follow YouTube video https://www.youtube.com/watch?v=bpTtbWgIgxQ on exporting DICOM Segmentation object. Fails to save object after error dialog is displayed.

Steps To Reproduce

Import DICOM series.
In Editor - add structure, draw some spheres.
Cilck button "Export DICOM SEG"
Then get dialog with failure message below.

Additional Information

"Failed to create temporary directory" "/var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer"
Session start time .......: 2016-06-03 13:00:35
Slicer version ...........: 4.5.0-2016-06-02 (revision 25149) macosx-amd64 - installed
Operating system .........: Mac OS X / 10.11.5 / 15F34 - 64-bit
Memory ...................: 16384 MB physical, 2048 MB virtual
CPU ......................: GenuineIntel Intel(R) Core(TM) i7-4770HQ CPU @ 2.20GHz, 4 cores, 8 logical processors
Developer mode enabled ...: no
Prefer executable CLI ....: no
Additional module paths ..: /Applications/Slicer.app/Contents/Extensions-25149/Reporting/lib/Slicer-4.5/cli-modules, /Applications/Slicer.app/Contents/Extensions-25149/Reporting/lib/Slicer-4.5/qt-scripted-modules
"Failed to create temporary directory" "/var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer"
Number of registered modules: 147
Number of instantiated modules: 147
When loading module "CLIEventTest" , the dependency "CLI4Test" failed to be loaded.
Initializing terminology mapping for map file /Applications/Slicer.app/Contents/share/Slicer-4.5/ColorFiles/Terminology//GenericAnatomyColors-SNOMED.csv
288 terms were read for Slicer LUT GenericAnatomyColors
When loading module "TwoCLIsInARowTest" , the dependency "CLI4Test" failed to be loaded.
When loading module "TwoCLIsInParallelTest" , the dependency "CLI4Test" failed to be loaded.
Number of loaded modules: 144
Switch to module: "Welcome"
Switch to module: "DICOM"
MultiVolumeImportPlugin::examine
DICOMMultiVolumePlugin found 0 multivolumes!
MultiVolumeImportPlugin:examineMultiseries
DICOMMultiVolumePlugin found 0 multivolumes!
Window/level found in DICOM tags (center=282.0, width=626.0) has been applied to volume 5342: T1_MPRAGE_iso_short
Loaded volume from file: /Users/mesozoic/Documents/SlicerDICOMDatabase/dicom/1.3.12.2.1107.5.2.30.25096.30000016032513260478800000037/1.3.6.1.4.1.19291.2.1.2.124492137163136167485814612975/1.2.276.0.7238010.5.1.4.0.24102.1464121814.352. Dimensions: 384x384x176. Number of components: 1. Pixel type: unsigned short.

Window/level found in DICOM tags (center=282.0, width=626.0) has been applied to volume 5342: T1_MPRAGE_iso_short
Switch to module: "Editor"
2016-06-03 13:01:12.889 Slicer[2509:27014] modalSession has been exited prematurely - check for a reentrant call to endModalSession:
Saving to /var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer/bone120035983.nrrd...
"Failed to create temporary directory" "/var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer"

itk::ExceptionObject (0x135e843c8)
Location: "unknown"
File: /Users/kitware/Dashboards/Nightly/Slicer-0-build/ITKv4/Modules/IO/NRRD/src/itkNrrdImageIO.cxx
Line: 1120
Description: itk::ERROR: NrrdImageIO(0x129c1ae60): Write: Error writing /var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer/bone120035983.nrrd:
[nrrd] nrrdSave: couldn't fopen("/var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer/bone120035983.nrrd","wb"): No such file or directory

"Slicer has caught an internal error.

You may be able to continue from this point, but results are undefined.

Suggested action is to save your work and restart.

If you have a repeatable sequence of steps that causes this message, please report the issue following instructions available at http://slicer.org

The message detail is:

Exception thrown in event: /Users/kitware/Dashboards/Nightly/Slicer-0-build/ITKv4/Modules/IO/NRRD/src/itkNrrdImageIO.cxx:1120:
itk::ERROR: NrrdImageIO(0x129c1ae60): Write: Error writing /var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer/bone120035983.nrrd:
[nrrd] nrrdSave: couldn't fopen("/var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer/bone120035983.nrrd","wb"): No such file or directory
"
2016-06-03 13:02:19.916 Slicer[2509:27014] modalSession has been exited prematurely - check for a reentrant call to endModalSession:

TagsNo tags attached.

Activities

Sean Doyle

Sean Doyle

2016-06-03 13:31

reporter   ~0013937

I did reboot my machine and run disk utilities to fix permissions on the files. The error is the same.

fedorov

fedorov

2016-06-03 13:49

developer   ~0013938

It looks like the permissions to the temp dir is not good. Can you
launch Slicer, open python terminal, "command+3", type

slicer.app.temporaryPath

and then check on the console the permissions for that directory? What are they?

Sean Doyle

Sean Doyle

2016-06-03 13:53

reporter   ~0013939

Directory doesn't appear to be there:

slicer.app.temporaryPath
u'/var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer'

Some of the subdirectories are also missing:
swd0-mac:var mesozoic$ ls -l /var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer
ls: /var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T/Slicer: No such file or directory

swd0-mac:var mesozoic$ ls -l /var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T
ls: /var/folders/zk/nm_5psr91yb3_yht5skh64h40000gq/T: No such file or directory

swd0-mac:var mesozoic$ ls -l /var/folders/zk
total 0
drwxr-xr-x 6 mesozoic staff 204 Jun 3 12:02 nm_5psr91yb3_yht5skh64h40000gr

fedorov

fedorov

2016-06-03 13:54

developer   ~0013940

You checked that path with the Slicer instance still running, correct? I can't explain this ...

Sean Doyle

Sean Doyle

2016-06-03 14:08

reporter   ~0013941

Yes. It looks like Slicer isn't creating this directory. It is currently running. Is there an earlier build I should try or something else that could isolate the issue?

fedorov

fedorov

2016-06-03 14:43

developer   ~0013942

I've just talked with Steve, no idea what's going on... Do you have any interesting errors/messages in the log? (Help > Report a bug) or python console?

pieper

pieper

2016-06-03 14:43

administrator   ~0013943

I have an idea: do you happen to share a home directory across multiple macs? Or maybe you brought the settings file from one machine to another?

Internally slicer keeps a persistent temp dir in the settings. If it can't find the settings it creates a new directory but if the settings exist but not the directory it might fail.

Try removing the settings file:

http://wiki.slicer.org/slicerWiki/index.php/Documentation/4.5/SlicerApplication/Settings

These are the implementation details:

https://github.com/Slicer/Slicer/blob/79bca4b65cdd9d09b4b4d7541d88738df625185f/Base/QTCore/qSlicerCoreApplication.cxx#L1136-L1151

http://doc.qt.io/qt-4.8/qdir.html#tempPath

Sean Doyle

Sean Doyle

2016-06-03 15:00

reporter   ~0013945

Deleting the settings file worked. Thanks!

fedorov

fedorov

2016-06-03 15:11

developer   ~0013946

Good to know for the future, thanks

Issue History

Date Modified Username Field Change
2016-06-03 13:15 Sean Doyle New Issue
2016-06-03 13:31 Sean Doyle Note Added: 0013937
2016-06-03 13:49 fedorov Assigned To => fedorov
2016-06-03 13:49 fedorov Status new => assigned
2016-06-03 13:49 fedorov Note Added: 0013938
2016-06-03 13:53 Sean Doyle Note Added: 0013939
2016-06-03 13:54 fedorov Note Added: 0013940
2016-06-03 14:08 Sean Doyle Note Added: 0013941
2016-06-03 14:43 fedorov Note Added: 0013942
2016-06-03 14:43 pieper Note Added: 0013943
2016-06-03 15:00 Sean Doyle Note Added: 0013945
2016-06-03 15:11 fedorov Note Added: 0013946
2016-06-03 15:11 fedorov Status assigned => resolved
2016-06-03 15:11 fedorov Resolution open => no change required