View Issue Details

IDProjectCategoryView StatusLast Update
0004231Slicer4Core: Extensionspublic2018-05-29 14:22
ReporterfedorovAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version 
Target VersionSlicer 4.11.0Fixed in VersionSlicer 4.9.0 
Summary0004231: Extension icon in Extension manager is not the same as specified in s4ext file
Description

From Andrey:

SlicerPathology s4ext file points to this as the extension icon:

https://raw.githubusercontent.com/SBU-BMI/SlicerPathology/master/SlicerPathology.png

(see https://github.com/Slicer/ExtensionsIndex/blob/master/SlicerPathology.s4ext)

However, extension manager in the latest nightly shows old icon. See attachment.

(note that the Revision correctly lists the latest version of SlicerPathology trunk that has the updated icon: SBU-BMI/SlicerPathology@ae5d1c4)

TagsNo tags attached.

Relationships

related to 0002171 assignedmatthew-woehlke Integrate extension license information on the extension server 
related to 0002334 assignedmatthew-woehlke Differentiate different type of extenions in extension manager: Concept of channel 

Activities

jcfr

jcfr

2016-07-07 23:20

administrator  

fedorov

fedorov

2016-10-12 14:39

developer   ~0014184

As was identified later, it appears that this is happening because Slicer extensions build system ignores the icon specified in the s4ext file, and instead uses the one from CMakeLists.txt.

It is not clear whether this is a bug, or intentional behavior.

Is is clear though that this situation is rather confusing to the developer...

lassoan

lassoan

2017-09-27 09:30

developer   ~0015142

Added note to documentation to clarify: https://www.slicer.org/wiki/Documentation/Nightly/Developers/Extensions/DescriptionFile.

For Slicer5, a new extension description format should be created and the redundancy between CMakeLists.txt and s4ext file should be removed. See discussion at https://www.slicer.org/wiki/Documentation/Labs/ExtensionsMetadata.

fedorov

fedorov

2017-09-27 10:51

developer   ~0015160

I will confirm this tomorrow after I see the dashboard, but -- related to this issue -- it looks like build_subdirectory is ignored in CMakeLists.txt, and is taken from s4ext...

fedorov

fedorov

2017-09-28 11:30

developer   ~0015212

Confirmed - build_subdirectory is ignored in CMakeLists.txt. For the superbuild extensions, it must be populated in s4ext. Demonstrated on the example of PkModeling extension that we recently moved to superbuild.

jcfr

jcfr

2017-10-03 02:12

administrator   ~0015238

Indeed, the value of build_subdirectory from the description is only used by the extension build system to find out in which sub directory the "packageupload" target should be built from. See [1]

[1] https://www.slicer.org/wiki/Documentation/Nightly/Developers/FAQ#How_to_upload_an_extension_.3F

jcfr

jcfr

2018-05-29 14:20

administrator   ~0015768

Last edited: 2018-05-29 14:22

View 2 revisions

Closing . URL was improperly specified.

In the future, we will improve how metadata are specified to avoid similar issue.

For the record:

  • metadata, file to be compiled, resources, ... are all specified in the CMakeLists.txt
  • the extension description file is currently a by product of the configuration/build step

Issue History

Date Modified Username Field Change
2016-07-07 23:19 jcfr New Issue
2016-07-07 23:19 jcfr Status new => assigned
2016-07-07 23:19 jcfr Assigned To => jcfr
2016-07-07 23:20 jcfr Description Updated View Revisions
2016-07-07 23:20 jcfr File Added: 1fcdf364-4461-11e6-99a3-9230fca08cf1.png
2016-07-07 23:20 jcfr Reporter jcfr => fedorov
2016-10-12 14:25 jcfr Target Version Slicer 4.6.0 => Slicer 4.7.0
2016-10-12 14:39 fedorov Note Added: 0014184
2017-09-27 09:30 lassoan Note Added: 0015142
2017-09-27 09:32 lassoan Target Version Slicer 4.7.0 => Slicer 4.9.0
2017-09-27 09:32 lassoan Summary Issue with extension icon => Extension icon in Extension manager is not the same as specified in s4ext file
2017-09-27 10:16 lassoan Relationship added related to 0002171
2017-09-27 10:17 lassoan Relationship added related to 0002334
2017-09-27 10:51 fedorov Note Added: 0015160
2017-09-28 11:30 fedorov Note Added: 0015212
2017-10-03 02:12 jcfr Note Added: 0015238
2018-03-31 00:37 jcfr Target Version Slicer 4.9.0 => Slicer 4.11.0
2018-05-29 14:20 jcfr Status assigned => resolved
2018-05-29 14:20 jcfr Resolution open => no change required
2018-05-29 14:20 jcfr Fixed in Version => Slicer 4.9.0
2018-05-29 14:20 jcfr Note Added: 0015768
2018-05-29 14:22 jcfr Note Edited: 0015768 View Revisions