View Issue Details

IDProjectCategoryView StatusLast Update
0004260Slicer4Extension: (Any extensions)public2017-06-10 17:50
ReportercriskrossAssigned Tolassoan 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0004260: Segment Editor Effect remains being active after adding, removing segment when the effect was used before for another segment
Description

Effects should always be disabled after adding/removing of a segment.

Buttons are grayed out, but EffectTool can still be active when used before adding/removing.

Undo/Redo history is also touched without even having a segment selected..

Steps To Reproduce
  1. Open Segment Editor
  2. Create new segment
  3. Paint something by using PaintEffect
  4. Add segment
  5. Hovering over slice view indicates, that PaintEffect is still active and it seems, that the undo/redo history is also touched, when just starting to draw something even when nothing appears afterwards.
Additional Information

ErrorLog:
virtual void qSlicerSegmentEditorAbstractEffect::modifySelectedSegmentByLabelmap(vtkOrientedImageData , qSlicerSegmentEditorAbstractEffect::ModificationMode, const int ) : Invalid segment selection

TagsNo tags attached.

Activities

lassoan

lassoan

2017-06-10 17:50

developer   ~0014743

It is not reproducible anymore in Slicer 4.7.0-2017-06-02 (Windows 10)

Issue History

Date Modified Username Field Change
2016-09-20 16:15 criskross New Issue
2016-09-20 16:16 criskross Summary Segment Editor Effect still active when adding, removing segment => Segment Editor Effect remains being active after adding, removing segment when the effect was used before for another segment
2017-06-10 17:50 lassoan Assigned To => lassoan
2017-06-10 17:50 lassoan Status new => resolved
2017-06-10 17:50 lassoan Resolution open => unable to reproduce
2017-06-10 17:50 lassoan Note Added: 0014743