View Issue Details

IDProjectCategoryView StatusLast Update
0004262Slicer4Core: Segmentationpublic2017-04-30 15:54
ReportercriskrossAssigned Tolassoan 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in VersionSlicer 4.8.1 
Summary0004262: Segmentation export into labelmap after Segment color changed, remains the same color as used for painting
Description

Exporting a segment for the second time into a labelmap after changing a segments color remains in displaying the same color as it was when created the first time.

Steps To Reproduce
  1. Switch to module Segment Editor
  2. Create a segmentation by means of the paint effect tool (blue color)
  3. Switch to Segmentations module
  4. Create a new labelmap in section Copy/move segment
  5. Select Segment_0 and use button +> to copy the segment to the labelmap
  6. Change the color of the segment (for instance to green)
  7. Repeat step 5

You will notice, that the segment color itself changed in the editor and the way it is displayed, but when you hide the segmentation and display the labelmap, the label will still appear with the same color as was when created the first time

Additional Information

Even creating a new labelmap does not fix the issue

TagsNo tags attached.

Activities

pinter

pinter

2016-09-22 15:57

developer   ~0014122

Color management will completely change when switching to terminologies. The reason I did not fix this issue is that the time I spend fixing this can be spent developing terminologies, which will make the current color handling (and this bug) obsolete

criskross

criskross

2016-09-22 16:26

developer   ~0014124

Ok good to know. When will the new terminology (widget) be available?

pinter

pinter

2016-09-22 21:05

developer   ~0014125

Hopefully in a few weeks. I'll leave for vacation mid-October and I want to get this done before that.
It is my highest priority now, and I'm working on the terminologies after I cleaned up the segmentations a bit (getting rid of the legacy labelmap support that necessitated using a color table etc).

lassoan

lassoan

2017-04-30 15:53

developer   ~0014471

This is fixed in recent nightly versions.

Issue History

Date Modified Username Field Change
2016-09-22 15:14 criskross New Issue
2016-09-22 15:14 criskross Status new => assigned
2016-09-22 15:14 criskross Assigned To => pinter
2016-09-22 15:14 criskross Summary Segmentation export after Segment color changed, remains the same color as used for painting => Segmentation export into labelmap after Segment color changed, remains the same color as used for painting
2016-09-22 15:57 pinter Note Added: 0014122
2016-09-22 16:26 criskross Note Added: 0014124
2016-09-22 21:05 pinter Note Added: 0014125
2017-04-30 15:53 lassoan Note Added: 0014471
2017-04-30 15:53 lassoan Status assigned => closed
2017-04-30 15:54 lassoan Assigned To pinter => lassoan
2017-04-30 15:54 lassoan Resolution open => fixed
2017-04-30 15:54 lassoan Fixed in Version => Slicer 4.8.1