View Issue Details

IDProjectCategoryView StatusLast Update
0004274Slicer4Core: Segmentationpublic2017-04-30 15:27
ReporterrankinAssigned Tolassoan 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in VersionSlicer 4.8.1 
Summary0004274: Slice interpolation access
Description

After giving multiple tutorial sessions on using Slicer for image segmentation, slice interpolation was one of the most requested features!

With the implementation complete, I notice that it is an option under the generically named "Smoothing" tool.

I would highly recommend that the Slice interpolation be given it's own button on the main list of functions, as it is so highly used. I haven't investigated the other smoothing options, but perhaps they should have their own buttons as well.

Steps To Reproduce

Install nightly.
Load image data.
Go to segmentation editor module.
Explore smoothing effect UI.

TagsNo tags attached.

Activities

lassoan

lassoan

2016-10-11 17:16

developer   ~0014148

I agree that the feature is kind of buried and it would be easier to find if it had a separate icon.

lassoan

lassoan

2016-10-15 13:39

developer   ~0014196

Now the feature is available in the "Auto-complete" effect.
There are two options:

  • fill between parallel slices (you completely segment a couple of slices and from that a full segmentation is computed)
  • grow from seeds (place seeds inside structures and they will be grown in 3D to partition the volume; using a cleaned up, optimized version of the fast growcut algorithm)

The auto-complete effect now also has a preview feature, so you can inspect the segmentation and make adjustments in the input before accepting the final result.

fepegar

fepegar

2016-10-20 10:31

reporter   ~0014208

Can one modify the parameters of the "Auto-complete" effect?

lassoan

lassoan

2016-10-20 11:27

developer   ~0014210

Both algorithms are great in the sense that they work optimally without requiring the user to tune any parameters. The only inputs users have to give is the partial segmentation. Do you have any particular behavior that you would like to control?

lassoan

lassoan

2016-10-20 11:29

developer   ~0014211

Also note that in tomorrow's nightly build there will be an auto-update option. This allows real-time preview of final segmentation for cases when update is very quick (mainly for "Grow from seeds" method for relatively small regions).

fepegar

fepegar

2016-10-20 11:31

reporter   ~0014212

No, I think I said that because I tried once and didn't like how the result looked in 3D, but I guess that's a matter of modifying the parameters of the conversion to model, which I can change in Segmentations or convert it by myself after exporting the segmentation to a label map.

lassoan

lassoan

2016-10-20 11:34

developer   ~0014213

Yes, 3D model generation parameters are currently not very convenient to tune (you need to go to Segmentations module, select click Update button next to Closed surface representation, choose "binary labelmap->closed surface" rule, modify smoothing factor). We'll figure out a way to make it simpler.

lassoan

lassoan

2017-04-30 15:27

developer   ~0014465

Interpolation between slices is available as a separate effect now.

Issue History

Date Modified Username Field Change
2016-10-07 11:44 rankin New Issue
2016-10-07 11:44 rankin Status new => assigned
2016-10-07 11:44 rankin Assigned To => pinter
2016-10-11 17:16 lassoan Note Added: 0014148
2016-10-14 09:27 pinter Assigned To pinter => lassoan
2016-10-15 13:39 lassoan Note Added: 0014196
2016-10-20 10:31 fepegar Note Added: 0014208
2016-10-20 11:27 lassoan Note Added: 0014210
2016-10-20 11:29 lassoan Note Added: 0014211
2016-10-20 11:31 fepegar Note Added: 0014212
2016-10-20 11:34 lassoan Note Added: 0014213
2017-04-30 15:27 lassoan Note Added: 0014465
2017-04-30 15:27 lassoan Status assigned => closed
2017-04-30 15:27 lassoan Resolution open => fixed
2017-04-30 15:27 lassoan Fixed in Version => Slicer 4.8.1