View Issue Details

IDProjectCategoryView StatusLast Update
0004296Slicer4Core: Packagingpublic2018-03-31 01:52
ReporterjcfrAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product VersionSlicer 4.6.2 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0004296: Package upload: Release field should automatically be set
Description

The update of the "release" field in the database has always been done after the experimental package were generated. Indeed, looking at either the old [1] or new [2] upload code, the release field is not set.

[1] https://github.com/Slicer/Slicer/blob/ffc788d9e4f6186cbc00033bd70fb040ce2dabfa/CMake/SlicerDashboardDriverScript.cmake#L362-L373

[2] https://github.com/Slicer/Slicer/blob/0087852de986548a5f61e8fd9280339c66080e06/CMake/SlicerPackageAndUploadTarget.cmake#L234-L246

To streamline the release process and avoid manual update of the midas database, the field should automatically be set if ALL these conditions are met:

  • package is Linux or MacOSX
  • package is a release

Notes:

  • Windows should not be associated with a release field because it is manually downloaded, signed and re-upload as a new package with the release field set. Using the attached script.

  • download.slicer.org is not able to detect when release field of packages is updated after it has updated his cache of the packages. The value is "sticky".
TagsNo tags attached.

Activities

lassoan

lassoan

2017-09-27 10:54

developer   ~0015162

@jcfr is this still a problem?

jcfr

jcfr

2018-03-31 01:35

administrator   ~0015634

Closing. This is now tracked in https://github.com/girder/slicer_package_manager/issues/60

jcfr

jcfr

2018-03-31 01:52

administrator   ~0015635

See also https://github.com/girder/slicer_package_manager/issues/61

Issue History

Date Modified Username Field Change
2016-11-08 11:50 jcfr New Issue
2016-11-08 11:50 jcfr Status new => assigned
2016-11-08 11:50 jcfr Assigned To => jcfr
2016-11-08 11:52 jcfr File Added: upload-Slicer-to-slicer-kitware-com.cmake
2017-09-27 10:54 lassoan Note Added: 0015162
2017-10-03 02:25 jcfr File Deleted: upload-Slicer-to-slicer-kitware-com.cmake
2017-10-03 02:26 jcfr Status assigned => resolved
2017-10-03 02:26 jcfr Resolution open => fixed
2017-10-03 02:26 jcfr Fixed in Version => Slicer 4.7.0
2017-10-03 02:28 jcfr Status resolved => assigned
2017-10-18 01:08 jcfr Target Version Slicer 4.7.0 => Slicer 4.9.0
2018-03-31 01:35 jcfr Status assigned => resolved
2018-03-31 01:35 jcfr Resolution fixed => no change required
2018-03-31 01:35 jcfr Fixed in Version Slicer 4.7.0 => Slicer 4.9.0
2018-03-31 01:35 jcfr Note Added: 0015634
2018-03-31 01:52 jcfr Note Added: 0015635