View Issue Details

IDProjectCategoryView StatusLast Update
0004301Slicer4Core: Packagingpublic2017-02-02 13:31
ReporternmsetAssigned Tojcfr 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformArchLinuxOSArchLinuxOS VersionArchLinux
Product Version 
Target VersionFixed in VersionSlicer 4.7.0 
Summary0004301: Linux nightly : ITK libraries missing
Description

Just downloaded Linux nightly build 2016-11-12 - revision 25524.
Slicer won't launch with this error :

libitkhdf5_cpp.so.1: cannot open shared object file

It's missing in ..../lib/Slicer-4.7/ .

Also, libitkhdf5.so.1 is located in ..../lib/ , and not in ..../lib/Slicer-4.7/ .

Steps To Reproduce

Unpack Linux nightly build 2016-11-12 (revision 25524) and start Slicer from CLI.

TagsNo tags attached.

Relationships

has duplicate 0004302 closedjcfr Can't open latest Slicer 

Activities

nmset

nmset

2016-12-03 15:51

reporter  

Slicer_itkhdf5_packaging.diff (2,173 bytes)
diff -ur a/Slicer-SuperBuild/ITKv4-build/Modules/ThirdParty/HDF5/src/itkhdf5/src/cmake_install.cmake b/Slicer-SuperBuild/ITKv4-build/Modules/ThirdParty/HDF5/src/itkhdf5/src/cmake_install.cmake
--- a/Slicer-SuperBuild/ITKv4-build/Modules/ThirdParty/HDF5/src/itkhdf5/src/cmake_install.cmake	2016-12-03 21:15:52.249676141 +0100
+++ b/Slicer-SuperBuild/ITKv4-build/Modules/ThirdParty/HDF5/src/itkhdf5/src/cmake_install.cmake	2016-12-03 21:26:35.262985593 +0100
@@ -34,8 +34,10 @@
 
 if("${CMAKE_INSTALL_COMPONENT}" STREQUAL "libraries" OR NOT CMAKE_INSTALL_COMPONENT)
   foreach(file
-      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/libitkhdf5.so.1"
-      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/libitkhdf5.so"
+      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/Slicer-4.7/libitkhdf5.so.1"
+      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/Slicer-4.7/libitkhdf5.so"
+      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/Slicer-4.7/libitkhdf5_cpp.so.1"
+      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/Slicer-4.7/libitkhdf5_cpp.so"
       )
     if(EXISTS "${file}" AND
        NOT IS_SYMLINK "${file}")
@@ -44,13 +46,17 @@
            RPATH "")
     endif()
   endforeach()
-  file(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/lib" TYPE SHARED_LIBRARY FILES
+  file(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/Slicer-4.7" TYPE SHARED_LIBRARY FILES
     "/home/user/src/Slicer-SuperBuild/ITKv4-build/lib/libitkhdf5.so.1"
     "/home/user/src/Slicer-SuperBuild/ITKv4-build/lib/libitkhdf5.so"
+    "/home/user/src/Slicer-SuperBuild/ITKv4-build/lib/libitkhdf5_cpp.so.1"
+    "/home/user/src/Slicer-SuperBuild/ITKv4-build/lib/libitkhdf5_cpp.so"
     )
   foreach(file
-      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/libitkhdf5.so.1"
-      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/libitkhdf5.so"
+      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/Slicer-4.7/libitkhdf5.so.1"
+      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/Slicer-4.7/libitkhdf5.so"
+      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/Slicer-4.7/libitkhdf5_cpp.so.1"
+      "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/Slicer-4.7/libitkhdf5_cpp.so"
       )
     if(EXISTS "${file}" AND
        NOT IS_SYMLINK "${file}")
nmset

nmset

2016-12-03 15:54

reporter   ~0014262

Uploaded file 'Slicer_itkhdf5_packaging.diff' allows a correct packaging of Linux builds.

It updates 'Slicer-SuperBuild/ITKv4-build/Modules/ThirdParty/HDF5/src/itkhdf5/src/cmake_install.cmake', which is itself a generated file. I don't know how it gets generated to patch upstream.

I hope it helps to get the Linux nightly builds working.

jcfr

jcfr

2017-01-05 21:19

administrator   ~0014286

Fixed in r25631
See http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=25631

pieper

pieper

2017-02-02 13:31

administrator   ~0014327

Works for me.

Issue History

Date Modified Username Field Change
2016-11-12 05:36 nmset New Issue
2016-11-12 05:36 nmset Status new => assigned
2016-11-12 05:36 nmset Assigned To => jcfr
2016-11-14 13:59 pieper Relationship added has duplicate 0004302
2016-12-03 15:51 nmset File Added: Slicer_itkhdf5_packaging.diff
2016-12-03 15:54 nmset Note Added: 0014262
2017-01-05 21:19 jcfr Note Added: 0014286
2017-01-05 21:19 jcfr Status assigned => resolved
2017-01-05 21:19 jcfr Fixed in Version => Slicer 4.7.0
2017-01-05 21:19 jcfr Resolution open => fixed
2017-02-02 13:31 pieper Note Added: 0014327
2017-02-02 13:31 pieper Status resolved => closed