View Issue Details

IDProjectCategoryView StatusLast Update
0004303Slicer4Module (Any modules)public2018-05-30 01:13
ReportermirclemAssigned Topieper 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformMacOSEl CapitanOS Version10.11
Product VersionSlicer 4.6.0 
Target VersionFixed in Version 
Summary0004303: Saving data from 'data' module not keeping the saved file name
Description

I had a feedback from my lab about saving data. They were saving data from the data module and renamed the file into a new one after a modification. But Slicer keeps in the scene a link with the old file and not the just saved one.
I know that's not a bug but it would be more user-friendly to keep the link to the just saved file. My opinion about that is if you are saving a file with a different name, you just did a new step in your pipeline, so let's restart from that new step.
They know that since a while, so they know they have to be cautious and load the just saved file to use it, so that's not a problem. It would make gain time in their opinion.

Steps To Reproduce
  • Load data (for example: file1.vtk)
  • Click on the data module
  • Change the file name (file2.vtk) and save it
  • Open the Transform module (for example)
  • In the list of data will be file1.vtk instead of file2.vtk
TagsNo tags attached.

Relationships

duplicate of 0003890 acknowledgedpieper Renaming node in the scene changes the filename in the storage node 

Activities

lassoan

lassoan

2017-06-15 15:58

developer   ~0014886

Do you mean that it is a problem that in the Save data dialog the default file names are always generated from the corresponding node name?

mirclem

mirclem

2017-06-15 16:33

reporter   ~0014888

Some people just think that when they save a file from a node, the node name should become the same than the one they entered in the Save data dialog.

pieper

pieper

2018-04-26 17:03

administrator   ~0015681

Last edited: 2018-04-26 17:04

View 2 revisions

Things actually work in the opposite order: if you change the name of the node, then that name will be used as the default filename when you save and then things will be consistent.

That is, the node name drives the filename on save, but the filename drives the node name when adding data and other than that they are disconnected and can differ.

Issue History

Date Modified Username Field Change
2016-11-17 16:16 mirclem New Issue
2017-06-15 15:58 lassoan Note Added: 0014886
2017-06-15 16:33 mirclem Note Added: 0014888
2017-07-24 23:58 lassoan Status new => acknowledged
2017-07-24 23:58 lassoan Summary Saving data from 'data' module not keeping the saved file => Saving data from 'data' module not keeping the saved file name
2017-07-24 23:59 lassoan Relationship added duplicate of 0003890
2018-04-26 17:03 pieper Assigned To => pieper
2018-04-26 17:03 pieper Status acknowledged => feedback
2018-04-26 17:03 pieper Note Added: 0015681
2018-04-26 17:04 pieper Note Edited: 0015681 View Revisions
2018-05-30 01:13 lassoan Status feedback => resolved
2018-05-30 01:13 lassoan Resolution open => duplicate