View Issue Details

IDProjectCategoryView StatusLast Update
0004322Slicer4Core: Base Codepublic2017-06-15 10:58
ReporterpieperAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformOSmacOS Version
Product Version 
Target VersionFixed in Version 
Summary0004322: old settings files can contain invalid path to temp directory
Description

On startup slicer looks in the settings and if it finds a TemporaryPath it tries to use it without checking validity [1].

https://github.com/Slicer/Slicer/blob/aca0f5db2ccf41f4b3a399b2346c2ed871fe5e6d/Base/QTCore/qSlicerCoreApplication.cxx#L1137-L1152

On mac, the temp dir can change from time to time and an old path can become invalid, for example when upgrading the OS. Also it is machine-specific, so a user that copies their home directory from one machine to another can end up with an invalid TemporaryPath.

The problem shows up when Slicer uses the temp path for something like saving an MRB.

Additional Information

Here's an email exchange between me and Ron that discusses the problem and the workaround.

Hi Steve,

Deleting Slicer.ini did the trick.

Ron

On Jan 8, 2017, at 1:59 PM, Steve Pieper <pieper@isomics.com> wrote:

Hi Ron -

Yes, it's probably because you still have the settings file from the older installation but the paths have changed.

You can delete (or just rename) this file:

~/.config/www.na-mic.org/Slicer.ini

You probably need to use a terminal to do it since it's invisible in the Finder.

If that turns out to be the issue we can file a bug report. This is the code that needs to be fixed.

https://github.com/Slicer/Slicer/blob/aca0f5db2ccf41f4b3a399b2346c2ed871fe5e6d/Base/QTCore/qSlicerCoreApplication.cxx#L1137-L1152

It gets the temp path from the user settings but doesn't check that it is usable.

I think we saw this last time you upgraded your laptop but we didn't fix it at the time. We're older and wiser now ; )

See you tomorrow,
Steve

On Sun, Jan 8, 2017 at 12:55 PM, Kikinis, Ron,M.D. <kikinis@bwh.harvard.edu> wrote:
Hi,

I just got my new mbp 2016 running the latest version of Sierra. When trying to save an mrb, I get the error message below.

Any recommendations?

Thanks

Ron

--
Ron Kikinis, M.D.,
Robert Greenes Distinguished Director of Biomedical Informatics
Professor of Radiology, Harvard Medical School
Director, Surgical Planning Laboratory
http://www.spl.harvard.edu/~kikinis

<Screen Shot 2017-01-08 at 12.41.03 PM.png>

<Screen Shot 2017-01-08 at 12.44.12 PM.png>

TagsNo tags attached.

Relationships

duplicate of 0004340 resolvedjcfr Impossible to use Slicer in multi-user setting on Linux 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-01-08 16:25 pieper New Issue
2017-01-08 16:25 pieper Status new => assigned
2017-01-08 16:25 pieper Assigned To => jcfr
2017-06-15 10:58 lassoan Relationship added duplicate of 0004340
2017-06-15 10:58 lassoan Status assigned => closed
2017-06-15 10:58 lassoan Resolution open => duplicate