View Issue Details

IDProjectCategoryView StatusLast Update
0004401Slicer4Module SubjectHierarchypublic2018-11-28 13:38
ReporterpinterAssigned Topinter 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product VersionSlicer 4.7.0 
Target VersionbacklogFixed in VersionSlicer 4.10.1 
Summary0004401: Improve subject hierarchy transform handling
Description

Issues with the current version:

  • Full transform name is not visible, only the first several letters. The field width also does not increase when the module is made wider (due to Qt limitation).
  • Having to double-click on the transform field in order to change the parent transform is a lot of interaction.
  • Access of transform hardening is inconsistent. In Data module it is in the context menu, on SH it is in the Transforms menu (bottom of the menu after double clicking)

Proposed changes:

  • Instead of the transform name, show an icon if the node is transform. There could be different icons for linear and deformable transforms.
  • Add harden transform in the right-click context menu for nodes that are transformed
  • Transforms plugin: Add new linear transform menu item (create new linear transform and switch to Transforms)
  • Open the transform menu with a single left-click on the icon. The transform menu would be the same as now. (Note: I think the user might be confused about the right-click context menu and the left-click transforms menu, but we could give a hint in a tooltip that appears for the icon or the empty transform cell) => I think Qt won't support single click for "editing" the table cell (Csaba)
Steps To Reproduce

Moved here from SlicerRT because Subject Hierarchy is now in Slicer core
https://app.assembla.com/spaces/slicerrt/tickets/769-improve-subject-hierarchy-transform-handling/details

TagsNo tags attached.

Activities

pinter

pinter

2018-11-23 14:12

developer   ~0016199

Change proposed in https://github.com/Slicer/Slicer/pull/1046

Right-click options were decided against at the end, because SH works quite differently compared to the transform hierarchy, where transforms are in the focus.

Issue History

Date Modified Username Field Change
2017-07-25 14:39 pinter New Issue
2017-07-25 14:39 pinter Status new => assigned
2017-07-25 14:39 pinter Assigned To => pinter
2018-11-23 14:12 pinter Note Added: 0016199
2018-11-28 13:38 pinter Status assigned => closed
2018-11-28 13:38 pinter Resolution open => fixed
2018-11-28 13:38 pinter Fixed in Version => Slicer 4.10.1