View Issue Details

IDProjectCategoryView StatusLast Update
0004420Slicer4Module DICOMpublic2017-09-27 17:27
ReporterfedorovAssigned Topieper 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSlicer 4.7.0 
Target VersionFixed in Version 
Summary0004420: Slicer DICOM import is order of magnitude slower than MITK
Description

Today I tried MITK, and I noticed that DICOM import operation is order of magnitude faster there than in Slicer.

I tested this specific dataset: https://bit.ly/QIN-HN-1371 on the same Linux system with the latest MITK package (2016.11) and the latest Slicer nightly. In MITK import of this dataset takes seconds, and in Slicer it is over 20 seconds. Considering both platforms are using the common set of components from CTK, is this behavior expected?

Steps To Reproduce

Import this dataset into DICOM Browser: https://bit.ly/QIN-HN-1371

Additional Information

Forum discussion: https://discourse.slicer.org/t/slicer-dicom-import-performance/922

TagsNo tags attached.

Activities

jcfr

jcfr

2017-08-22 23:30

administrator   ~0015070

Last edited: 2017-08-22 23:31

View 5 revisions

Look like there is something wrong with the bit.ly link.

In fact, the working link is https://bit.ly/QIN-HN-137

fedorov

fedorov

2017-08-22 23:44

developer   ~0015071

Sorry for the typo, it's https://bit.ly/QIN-HN-137

pieper

pieper

2017-09-21 18:40

administrator   ~0015115

Looks like the biggest performance issues are resolved.

@fedorov if you agree we can close this issue.

fedorov

fedorov

2017-09-27 17:27

developer   ~0015209

I tested today on a linux system with Slicer nightly as of Sept 27, and Slicer import is still about 3 times slower than MITK.

Issue History

Date Modified Username Field Change
2017-08-22 18:44 fedorov New Issue
2017-08-22 18:44 fedorov Status new => assigned
2017-08-22 18:44 fedorov Assigned To => pieper
2017-08-22 23:30 jcfr Note Added: 0015070
2017-08-22 23:31 jcfr Note Edited: 0015070 View Revisions
2017-08-22 23:31 jcfr Note Edited: 0015070 View Revisions
2017-08-22 23:31 jcfr Note Edited: 0015070 View Revisions
2017-08-22 23:31 jcfr Note Edited: 0015070 View Revisions
2017-08-22 23:44 fedorov Note Added: 0015071
2017-09-21 18:40 pieper Status assigned => resolved
2017-09-21 18:40 pieper Resolution open => fixed
2017-09-21 18:40 pieper Note Added: 0015115
2017-09-27 17:27 fedorov Note Added: 0015209