View Issue Details

IDProjectCategoryView StatusLast Update
0004439Slicer4Core: Building (CMake, Superbuild)public2018-05-30 13:24
ReporterpieperAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformmacOSOS Version
Product Version 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0004439: std::bind missing in SimpleITK build on mac
Description

Fresh build with SimpleITK enabled gives error pasted below. This appears to be an incompatibility with the latest Xcode.

$ xcodebuild -version
Xcode 9.0
Build version 9A235

Additional Information

In file included from /Users/pieper/slicer4/latest/Slicer-superbuild/SimpleITK/Code/Common/src/sitkImageExplicit.cxx:33:
In file included from /Users/pieper/slicer4/latest/Slicer-superbuild/SimpleITK/Code/Common/src/sitkImage.hxx:21:
In file included from /Users/pieper/slicer4/latest/Slicer-superbuild/SimpleITK/Code/Common/include/sitkImage.h:23:
In file included from /Users/pieper/slicer4/latest/Slicer-superbuild/SimpleITK/Code/Common/include/sitkDetail.h:21:
In file included from /Users/pieper/slicer4/latest/Slicer-superbuild/SimpleITK/Code/Common/include/sitkMemberFunctionFactoryBase.h:23:
/Users/pieper/slicer4/latest/Slicer-superbuild/SimpleITK/Code/Common/include/nsstd/functional.h:45:12: error: no member named 'bind' in namespace 'std'; did you mean 'find'?
using std::bind;
~^~~~
find
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/include/c++/v1/algorithm:888:1: note: 'find' declared here
find(_InputIterator first, _InputIterator __last, const _Tp& value_)
^

TagsNo tags attached.

Activities

lassoan

lassoan

2018-05-30 00:58

developer   ~0015818

Has this been fixed since then?

jcfr

jcfr

2018-05-30 13:09

administrator   ~0015849

ref https://github.com/SimpleITK/SimpleITK/issues/477

blowekamp

blowekamp

2018-05-30 13:18

developer   ~0015850

This looks like a C++11/libc++/stdlibc++ or SDK issue. The SimpleITK superbuild works find by default with the all Xcode versions.

With a recent OS X SDK which uses libc++ by default, SimpleITK will need to be compiled with C++11, this is automatically detected and enabled with the SimpleITK Superbuild.

jcfr

jcfr

2018-05-30 13:23

administrator   ~0015851

Last edited: 2018-05-30 13:24

View 2 revisions

Resolving. Following comment of @blowekamp, this is most likely an install problem (or incorrect CMAKE_OSX_* set of parameters)

@pieper: Please, re-open if you still have a problem.

jcfr

jcfr

2018-05-30 13:24

administrator   ~0015852

xref https://github.com/SimpleITK/SimpleITK/issues/477#issuecomment-393246647

Issue History

Date Modified Username Field Change
2017-09-21 18:07 pieper New Issue
2017-09-21 18:07 pieper Status new => assigned
2017-09-21 18:07 pieper Assigned To => jcfr
2018-05-30 00:58 lassoan Note Added: 0015818
2018-05-30 13:09 jcfr Note Added: 0015849
2018-05-30 13:18 blowekamp Note Added: 0015850
2018-05-30 13:23 jcfr Status assigned => resolved
2018-05-30 13:23 jcfr Resolution open => no change required
2018-05-30 13:23 jcfr Fixed in Version => Slicer 4.9.0
2018-05-30 13:23 jcfr Note Added: 0015851
2018-05-30 13:24 jcfr Note Added: 0015852
2018-05-30 13:24 jcfr Note Edited: 0015851 View Revisions