View Issue Details

IDProjectCategoryView StatusLast Update
0004458Slicer4Module Segment Editorpublic2018-05-30 01:38
ReporterhwinterAssigned Tolassoan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSUbuntuOS Version16.04
Product VersionSlicer 4.6.2 
Target VersionFixed in Version 
Summary0004458: Segment Editor paint and erase tools do not display circle
Description

When using the paint and eraser tools in the Segment Editor, the circle under the mouse cursor indicating the size of the tool does not show up. This functionality seems to work correctly in the regular Editor.

Steps To Reproduce

Open any DICOM file and attempt to paint or erase in the Segment Editor.

TagsNo tags attached.

Activities

pieper

pieper

2017-10-13 08:11

administrator   ~0015295

Please try the latest Nightly build. There have been a lot of fixes since the 4.6.2 release.

Thanks

hwinter

hwinter

2017-10-13 12:35

reporter   ~0015298

Yes, circle under the mouse cursor still does not show up in the latest nightly. :(

lassoan

lassoan

2017-10-13 12:36

developer   ~0015299

Can you record a screen capture video of what you do and post the link here?

hwinter

hwinter

2017-10-13 12:51

reporter   ~0015300

Thank you! Here are dropbox links (one is .mov and one is .avi just in case). The minor issue is that the circle visually indicating the radius of the paint/eraser doesn't show up in the segment editor. But in the editor it is there!

https://www.dropbox.com/s/u2zrqppnw4gbgk4/slicer-paint-linux.mov?dl=0
https://www.dropbox.com/s/fyn0b5h08yxj054/slicer-paint-linux.avi?dl=0

lassoan

lassoan

2017-10-13 12:54

developer   ~0015301

Thank you this was helpful. Does any other overlay show up (level tracing, threshold, scissors)?

hwinter

hwinter

2017-10-13 12:57

reporter   ~0015302

Ah, the threshold works but the level tracing and scissors do not.

lassoan

lassoan

2017-10-13 12:58

developer   ~0015303

Have you built Slicer yourself or downloaded from slicer.org?

hwinter

hwinter

2017-10-13 13:12

reporter   ~0015304

I have downloaded from slicer.org.

hwinter

hwinter

2017-10-13 20:14

reporter   ~0015311

I just tried the slicer nightly on a different linux machine and it worked correctly! So sorry about that. Thank you so much for you help and time!

lassoan

lassoan

2018-05-30 01:38

developer   ~0015830

The problem happened on a specific computer only and was not reproducible on others.

Issue History

Date Modified Username Field Change
2017-10-12 20:45 hwinter New Issue
2017-10-12 20:45 hwinter Status new => assigned
2017-10-12 20:45 hwinter Assigned To => pieper
2017-10-12 20:48 hwinter Description Updated View Revisions
2017-10-13 08:10 pieper Assigned To pieper => lassoan
2017-10-13 08:10 pieper Category Module Editor => Module Segment Editor
2017-10-13 08:11 pieper Status assigned => feedback
2017-10-13 08:11 pieper Note Added: 0015295
2017-10-13 12:35 hwinter Note Added: 0015298
2017-10-13 12:35 hwinter Status feedback => assigned
2017-10-13 12:36 lassoan Note Added: 0015299
2017-10-13 12:51 hwinter Note Added: 0015300
2017-10-13 12:54 lassoan Note Added: 0015301
2017-10-13 12:57 hwinter Note Added: 0015302
2017-10-13 12:58 lassoan Note Added: 0015303
2017-10-13 13:12 hwinter Note Added: 0015304
2017-10-13 20:14 hwinter Note Added: 0015311
2018-05-30 01:38 lassoan Status assigned => resolved
2018-05-30 01:38 lassoan Resolution open => unable to reproduce
2018-05-30 01:38 lassoan Note Added: 0015830