View Issue Details

IDProjectCategoryView StatusLast Update
0004472Slicer4Core: Extensionspublic2017-11-21 10:36
ReporterpinterAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product VersionSlicer 4.9.0 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0004472: Automatic test for extension cannot find dependency on factory
Description

I recently added this test
http://slicer.cdash.org/testDetails.php?test=8399131&build=1121694
When I run the test locally, it successfully finds the dependent modules (such as DicomRtImportExportModule that is not found on the factory). These lines were needed in the CMakeLists file so that these modules are correctly found
https://github.com/SlicerRt/GelDosimetryAnalysis/blob/master/GelDosimetryAnalysis/CMakeLists.txt#L52-L53
Maybe SlicerRT_DIR is not set on the factory when configuring GelDosimetryAnalysis?

TagsNo tags attached.

Activities

pinter

pinter

2017-11-02 11:15

developer   ~0015379

The problem may be related to the fact that the line
include(${Slicer_EXTENSION_GENERATE_CONFIG})
was not in the CMakeLists file. I'll report back when I find out if it improved things.

pinter

pinter

2017-11-06 15:07

developer   ~0015382

It didn't do the trick, but I'll keep trying.

jcfr

jcfr

2017-11-18 15:39

administrator   ~0015411

The issue is that SlicerRT extension generates its SlicerRTConfig file in the top level directory but the extension build system expects the file in the inner build directory.

Inseed, it sets SlicerRT_DIR appending the inner build directory.

See https://discourse.slicer.org/t/nightly-build-tests-failing-for-extensions-with-dependencies-to-other-scriptable-modules/1483/18

pinter

pinter

2017-11-21 10:36

developer   ~0015426

The test finds the dependencies and starts as expected, so I'm closing the issue.

I have one question though. There is an error in the test (which I'll fix), but the test passes. How can I make it fail if an exception happens? I can make any calls when handling the exception. Thanks!
http://slicer.cdash.org/testDetails.php?test=8440601&build=1134892

Issue History

Date Modified Username Field Change
2017-11-02 08:41 pinter New Issue
2017-11-02 08:41 pinter Status new => assigned
2017-11-02 08:41 pinter Assigned To => jcfr
2017-11-02 11:15 pinter Note Added: 0015379
2017-11-06 15:07 pinter Note Added: 0015382
2017-11-18 15:39 jcfr Status assigned => resolved
2017-11-18 15:39 jcfr Resolution open => no change required
2017-11-18 15:39 jcfr Fixed in Version => Slicer 4.9.0
2017-11-18 15:39 jcfr Note Added: 0015411
2017-11-21 10:36 pinter Status resolved => closed
2017-11-21 10:36 pinter Note Added: 0015426