View Issue Details

IDProjectCategoryView StatusLast Update
0004479Slicer4Core: Chartpublic2018-02-09 00:04
ReporternmsetAssigned Tojohan.andruejol 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSLinuxOS VersionArch rolling
Product Version 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0004479: Qt5 : crash on application closure if ChartView has been shown
Description

Using the Qt5 git build with qt5 5.9.3 on Arch Linux :

If the CharView has ever been shown, Slicer will crash on exit, whether a ChartView is on screen or not.

Steps To Reproduce

Show a ChartView instance, close app.

Additional Information
Thread 1 "SlicerApp-real" received signal SIGSEGV, Segmentation fault.
0x00007fffd596e3ef in QWidget::~QWidget() () from /usr/lib/libQt5Widgets.so.5
(gdb) backtrace
#0  0x00007fffd596e3ef in QWidget::~QWidget() () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=1" title="[closed] Closing scene freezes 3D viewer" class="resolved">0000001</a>  0x00007fffd596e82a in QWidget::~QWidget() () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=2" title="[closed] Overwriting existing model nodes with new geometry causes crashes" class="resolved">0000002</a>  0x00007fffd4c45b91 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
<a href="/view.php?id=3" title="[closed] Filebrowser in CommandLineModules defaults to searching for "txt" files." class="resolved">0000003</a>  0x00007fffd59731cc in QWidget::event(QEvent*) () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=4" title="[closed] Can't use third slice window at lower resolutions" class="resolved">0000004</a>  0x00007fffd5932f5c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=5" title="[closed] Start in volumes or data?" class="resolved">0000005</a>  0x00007fffd593aa36 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=6" title="[closed] Add model changes button" class="resolved">0000006</a>  0x00007ffff6ef2a59 in qSlicerApplication::notify(QObject*, QEvent*) (this=
    0x7fffffffe3f0, receiver=0x555557c82370, event=0x55555b7a5320) at /home/arc/src/Slicer/Base/QTGUI/qSlicerApplication.cxx:388
<a href="/view.php?id=7" title="[closed] Slicer crashes when trying to load non-image data" class="resolved">0000007</a>  0x00007fffd4c15570 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
<a href="/view.php?id=8" title="[closed] Slice number restore from MRML" class="resolved">0000008</a>  0x00007fffd4c17dc6 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
<a href="/view.php?id=9" title="[closed] fg/bg threshold issue with SPL atlas" class="resolved">0000009</a>  0x00007fffed61939e in  () at /usr/lib/libQt5Quick.so.5
<a href="/view.php?id=10" title="[closed] Keyboard shortcut for new fiducial list" class="resolved">0000010</a> 0x00007fffed619701 in QQuickRenderControl::~QQuickRenderControl() () at /usr/lib/libQt5Quick.so.5
<a href="/view.php?id=11" title="[acknowledged] Measure performance like Models/Meter in slicer 2.x">0000011</a> 0x00007fffc81cce84 in  () at /usr/lib/libQt5QuickWidgets.so.5
<a href="/view.php?id=12" title="[acknowledged] Sub-volume feature request">0000012</a> 0x00007fffc81cb653 in  () at /usr/lib/libQt5QuickWidgets.so.5
<a href="/view.php?id=13" title="[acknowledged] Moveable Windows">0000013</a> 0x00007fffc81cb6d9 in  () at /usr/lib/libQt5QuickWidgets.so.5
<a href="/view.php?id=14" title="[closed] Node Selector for Fibers" class="resolved">0000014</a> 0x00007fffd4c4c8f6 in QObject::~QObject() () at /usr/lib/libQt5Core.so.5
<a href="/view.php?id=15" title="[closed] model building fails with space in command line (temp dir)" class="resolved">0000015</a> 0x00007fffd596e656 in QWidget::~QWidget() () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=16" title="[closed] Problem with tooltips for FG/BG" class="resolved">0000016</a> 0x00007ffff4491292 in  () at /usr/lib/libQt5WebEngineWidgets.so.5
<a href="/view.php?id=17" title="[assigned] CommandLineModules do not clean up temporary files if the temporary files are separate header and bulk data files.">0000017</a> 0x00007fffee339512 in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=18" title="[closed] crash on exit after adding fiducial" class="resolved">0000018</a> 0x00007fffee339689 in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=19" title="[closed] ModuleDescription parser crashs Slicer if the xml string doesn't start with a <executable> tag" class="resolved">0000019</a> 0x00007fffee79aa2f in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=20" title="[closed] Importing an xml scene tutorial.xml crashes Slicer3" class="resolved">0000020</a> 0x00007fffee78f792 in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=21" title="[closed] Clicking the full screen icon doesn't work on Linux 64" class="resolved">0000021</a> 0x00007fffee5ea999 in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=22" title="[closed] Loading in /d/bigsur/slicerdata/cavernoma/cav.xml causes a segfault." class="resolved">0000022</a> 0x00007fffee6173ef in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=23" title="[closed] Loading /d/bigsur/slicerdata/BronchialTree/BronchialTree.xml crashes slicer" class="resolved">0000023</a> 0x00007fffee6179d9 in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=24" title="[feedback] Make fonts resizeable or make better font-size setting based on the system resolution.">0000024</a> 0x00007fffee61dc2d in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=25" title="[closed] Create functionality to define oblique cuts" class="resolved">0000025</a> 0x00007fffee5ed341 in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=26" title="[closed] /d/bigsur/slicerdata/cystoscopy/cystoscopy.xml doesn't load properly" class="resolved">0000026</a> 0x00007fffee5e83ba in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=27" title="[closed] Loading /d/bigsur/slicerdata/gynnulli/gynnulli.xml crashes Slicer3" class="resolved">0000027</a> 0x00007fffee85f6d6 in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=28" title="[closed] Loading /d/bigsur/slicerdata/avm/avm_reg1.xml crashes Slicer3" class="resolved">0000028</a> 0x00007fffee85f999 in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=29" title="[closed] Invalid temp directory under Ubuntu" class="resolved">0000029</a> 0x00007fffee35564e in  () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=30" title="[closed] camera nodes shows up in data tree" class="resolved">0000030</a> 0x00007fffee35591a in QtWebEngineCore::WebContentsAdapter::~WebContentsAdapter() () at /usr/lib/libQt5WebEngineCore.so.5
<a href="/view.php?id=31" title="[assigned] Feature request for mapping data to 3D surface">0000031</a> 0x00007ffff44811a6 in  () at /usr/lib/libQt5WebEngineWidgets.so.5
<a href="/view.php?id=32" title="[acknowledged] crash when trying to load int64 or uint64 volume">0000032</a> 0x00007ffff4481209 in  () at /usr/lib/libQt5WebEngineWidgets.so.5
<a href="/view.php?id=33" title="[closed] fit view to background doesn't always work" class="resolved">0000033</a> 0x00007ffff447b795 in QWebEnginePage::~QWebEnginePage() () at /usr/lib/libQt5WebEngineWidgets.so.5
<a href="/view.php?id=34" title="[closed] Interpolate checkbox on the VolumesDisplayGUI" class="resolved">0000034</a> 0x00007ffff447b7ba in QWebEnginePage::~QWebEnginePage() () at /usr/lib/libQt5WebEngineWidgets.so.5
<a href="/view.php?id=35" title="[closed] exporting floating point volumes" class="resolved">0000035</a> 0x00007fffd4c42c6d in QObjectPrivate::deleteChildren() () at /usr/lib/libQt5Core.so.5
<a href="/view.php?id=36" title="[resolved] command line modules don't run from within debugger" class="resolved">0000036</a> 0x00007fffd596e5c5 in QWidget::~QWidget() () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=37" title="[closed] Clicking on folder icon to Save a MRML scene or data to a file does nothing" class="resolved">0000037</a> 0x00007ffff6986196 in qMRMLChartView::~qMRMLChartView() (this=0x55555b6e7640, __in_chrg=<optimized out>)
---Type <return> to continue, or q <return> to quit---
    at /home/arc/src/Slicer/Libs/MRML/Widgets/qMRMLChartView.cxx:1717
<a href="/view.php?id=38" title="[resolved] Cannot read 3-D TIFF with color lookup tables" class="resolved">0000038</a> 0x00007ffff69861dd in qMRMLChartView::~qMRMLChartView() (this=0x55555b6e7640, __in_chrg=<optimized out>)
    at /home/arc/src/Slicer/Libs/MRML/Widgets/qMRMLChartView.cxx:1720
<a href="/view.php?id=39" title="[closed] Deleting a selected fiducial list causes unexpected behaviour" class="resolved">0000039</a> 0x00007fffd4c42c6d in QObjectPrivate::deleteChildren() () at /usr/lib/libQt5Core.so.5
<a href="/view.php?id=40" title="[closed] Blank popup message box when loading tutorial.xml" class="resolved">0000040</a> 0x00007fffd596e5c5 in QWidget::~QWidget() () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=41" title="[confirmed] Different default views of MRML scene in Slicer2 and Slicer3">0000041</a> 0x00007ffff6a925f3 in qMRMLWidget::~qMRMLWidget() (this=0x555557c82370, __in_chrg=<optimized out>)
    at /home/arc/src/Slicer/Libs/MRML/Widgets/qMRMLWidget.cxx:47
<a href="/view.php?id=42" title="[closed] Progress bar for loading MRML scenes" class="resolved">0000042</a> 0x00007ffff6992c98 in qMRMLChartWidget::~qMRMLChartWidget() (this=0x555557c82370, __in_chrg=<optimized out>)
    at /home/arc/src/Slicer/Libs/MRML/Widgets/qMRMLChartWidget.cxx:107
<a href="/view.php?id=43" title="[closed] Auto-thresholding not working for avm MRML scene" class="resolved">0000043</a> 0x00007ffff6992cdf in qMRMLChartWidget::~qMRMLChartWidget() (this=0x555557c82370, __in_chrg=<optimized out>)
    at /home/arc/src/Slicer/Libs/MRML/Widgets/qMRMLChartWidget.cxx:112
<a href="/view.php?id=44" title="[closed] scalar display for models" class="resolved">0000044</a> 0x00007fffd4c42c6d in QObjectPrivate::deleteChildren() () at /usr/lib/libQt5Core.so.5
<a href="/view.php?id=45" title="[closed] GE Signa files not supported due to ITK bugs" class="resolved">0000045</a> 0x00007fffd596e5c5 in QWidget::~QWidget() () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=46" title="[closed] vtkMRMLScene::GetNextNodeByClass Segementation faults" class="resolved">0000046</a> 0x00007fffd5a15e6a in QFrame::~QFrame() () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=47" title="[closed] hitting cancel on a non-running cli crashes slicer" class="resolved">0000047</a> 0x00007fffd4c42c6d in QObjectPrivate::deleteChildren() () at /usr/lib/libQt5Core.so.5
<a href="/view.php?id=48" title="[closed] alt-f-x crash" class="resolved">0000048</a> 0x00007fffd596e5c5 in QWidget::~QWidget() () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=49" title="[closed] need to be able to load a list of models from model maker" class="resolved">0000049</a> 0x00007fffd596e82a in QWidget::~QWidget() () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=50" title="[closed] MGH IO causes segfault on exit" class="resolved">0000050</a> 0x00007fffd4c42c6d in QObjectPrivate::deleteChildren() () at /usr/lib/libQt5Core.so.5
<a href="/view.php?id=51" title="[assigned] memory leak in registration causes crash">0000051</a> 0x00007fffd596e5c5 in QWidget::~QWidget() () at /usr/lib/libQt5Widgets.so.5
<a href="/view.php?id=52" title="[new] Alignments module: manual registration">0000052</a> 0x00007ffff7b13d90 in qSlicerAppMainWindow::~qSlicerAppMainWindow() (this=0x555556edd880, __in_chrg=<optimized out>)
    at /home/arc/src/Slicer/Applications/SlicerApp/qSlicerAppMainWindow.cxx:741
<a href="/view.php?id=53" title="[closed] Loading an XML scene in Slicer3" class="resolved">0000053</a> 0x00007ffff7b13dd7 in qSlicerAppMainWindow::~qSlicerAppMainWindow() (this=0x555556edd880, __in_chrg=<optimized out>)
    at /home/arc/src/Slicer/Applications/SlicerApp/qSlicerAppMainWindow.cxx:763
<a href="/view.php?id=54" title="[assigned] Easier access to module logic classes">0000054</a> 0x000055555555edf1 in QScopedPointerDeleter<qSlicerAppMainWindow>::cleanup(qSlicerAppMainWindow*) (pointer=0x555556edd880)
    at /usr/include/qt/QtCore/qscopedpointer.h:60
<a href="/view.php?id=55" title="[new] save clipped model">0000055</a> 0x000055555555e42a in QScopedPointer<qSlicerAppMainWindow, QScopedPointerDeleter<qSlicerAppMainWindow> >::~QScopedPointer() (this=0x7fffffffe388, __in_chrg=<optimized out>) at /usr/include/qt/QtCore/qscopedpointer.h:107
<a href="/view.php?id=56" title="[assigned] Relationships between CLI module parameters">0000056</a> 0x000055555555c20e in (anonymous namespace)::SlicerAppMain(int, char**) (argc=1, argv=0x7fffffffe598)
    at /home/arc/src/Slicer/Applications/SlicerApp/Main.cxx:207
<a href="/view.php?id=57" title="[resolved] Places Bar on Windows version keeps getting reset" class="resolved">0000057</a> 0x000055555555c608 in main(int, char**) (argc=1, argv=0x7fffffffe598)
    at /home/arc/src/Slicer/Applications/SlicerApp/Main.cxx:302
Tagsqt

Relationships

related to 0004508 assignednicole Qt5: Update SceneView to work with QtWebEngine 

Activities

johan.andruejol

johan.andruejol

2018-02-07 14:13

manager   ~0015511

PR to fix this here: https://github.com/Slicer/Slicer/pull/891

jcfr

jcfr

2018-02-09 00:01

administrator   ~0015513

Fixed in r26902

Issue History

Date Modified Username Field Change
2017-11-27 08:32 nmset New Issue
2017-11-27 08:32 nmset Status new => assigned
2017-11-27 08:32 nmset Assigned To => millerjv
2017-11-27 08:32 nmset Tag Attached: qt
2018-02-07 02:08 jcfr Additional Information Updated View Revisions
2018-02-07 02:12 jcfr Assigned To millerjv => johan.andruejol
2018-02-07 14:13 johan.andruejol Note Added: 0015511
2018-02-09 00:01 jcfr Status assigned => resolved
2018-02-09 00:01 jcfr Resolution open => fixed
2018-02-09 00:01 jcfr Fixed in Version => Slicer 4.9.0
2018-02-09 00:01 jcfr Note Added: 0015513
2018-02-09 00:04 jcfr Relationship added related to 0004508