View Issue Details

IDProjectCategoryView StatusLast Update
0004484Slicer4Core: Segmentationpublic2018-11-12 14:10
ReporterlassoanAssigned Topinter 
PrioritynormalSeverityfeatureReproducibilityN/A
Status assignedResolutionopen 
Product VersionSlicer 4.9.0 
Target VersionbacklogFixed in Version 
Summary0004484: Convert from master representation to others in background
Description

When editing segments in slice views and 3D view is enabled, for complex models 3D update may take several seconds after each editing operation.

It would be better to update 3D closed surface representation in the background and not block the main user interface during the update.
It would be also possible to display segments in 3D using volume rendering, but this would be too limited until multi-volume rendering will be available in VTK.

Workaround: Until background processing/multi-volume rendering is implemented, 3D model generation can be made faster by disabling smoothing (setting smoothing factor to 0).

TagsNo tags attached.

Activities

_-_-_

_-_-_

2018-05-16 04:38

reporter   ~0015715

Would be great if this improvement could be implemented in the near future ;-)

lassoan

lassoan

2018-05-16 07:39

developer   ~0015716

In recent nightly Slicer versions, conversion speed is so much improved that most likely background processing will not be necessary. The only processing step that is still slow is smoothing, which you can temporarily disable while you are editing the segmentation.

_-_-_

_-_-_

2018-05-16 09:58

reporter   ~0015717

Without smoothing it's very difficult to see very small tunnel between outer and inner surface, see the example below:



WithSmoothing.PNG (640,568 bytes)
WithSmoothing.PNG (640,568 bytes)
WithoutSmoothing.PNG (805,152 bytes)
WithoutSmoothing.PNG (805,152 bytes)
lassoan

lassoan

2018-05-16 10:03

developer   ~0015718

Yes, so once you finished with the segmentation, you can enable smoothing to do some more assessment. I find that for the most part, during interactive segmentation, smoothing is not essential. We may add a toggle to make allow enabling/disabling smoothing with a single click.

nick_slizer

nick_slizer

2018-05-16 15:34

reporter   ~0015719

@lassoan This works so well I'd suggest that the 3D toggle button be changed so that it flips between voxel and smooth mode. Or better, call it "Smooth", press to run-once, with a pull-down for mode changes. Default mode is update voxel 3D and then users won't ever have to change mode in most cases. The button could be greyed out when 3D smooth representation is current (after pressing it, before changing more voxels).

_-_-_

_-_-_

2018-05-18 07:39

reporter   ~0015722

Could be an option, to have an shortcut to switch between smoothing and no smoothing, if this is really faster than switching between "Show 3D" on/off.

But in my case that won't help much because I use a pen display for segmentation, and all eight hot keys are already assigned.

IMO, the clean solution would be to decouple 3D view and editing or to buy better hardware? ;-)

lassoan

lassoan

2018-11-12 13:07

developer   ~0016195

Smoothing enable/disable is now much more easily accessible in Segment Editor (https://discourse.slicer.org/t/option-to-disable-smoothing-of-the-segment-surfaces-in-segment-editor/883/16?u=lassoan).

Temporarily disabling smoothing and the potential of using multi-volume rendering for displaying segments, makes priority of this issue very low. I'm tempted to closed this issue.

pinter

pinter

2018-11-12 14:10

developer   ~0016196

I agree that this feature is not really needed at the moment. Also it is quite hard to implement, so considering its priority, it's unlikely that we'll do it in the foreseeable future.

This issue is already in backlog, but if you can't imagine any use case where background conversion would be necessary, the we could close this issue. Not sure about the criteria about keeping an issue in backlog or closing as invalid...

Issue History

Date Modified Username Field Change
2017-12-05 15:55 lassoan New Issue
2017-12-05 15:55 lassoan Status new => assigned
2017-12-05 15:55 lassoan Assigned To => pinter
2018-05-16 04:38 _-_-_ Note Added: 0015715
2018-05-16 07:39 lassoan Note Added: 0015716
2018-05-16 09:58 _-_-_ File Added: WithoutSmoothing.PNG
2018-05-16 09:58 _-_-_ File Added: WithSmoothing.PNG
2018-05-16 09:58 _-_-_ Note Added: 0015717
2018-05-16 10:03 lassoan Note Added: 0015718
2018-05-16 15:34 nick_slizer Note Added: 0015719
2018-05-18 07:39 _-_-_ Note Added: 0015722
2018-11-12 13:07 lassoan Note Added: 0016195
2018-11-12 14:10 pinter Note Added: 0016196