View Issue Details

IDProjectCategoryView StatusLast Update
0004492Slicer4Core: Chartpublic2018-02-07 14:56
ReporterDavideAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionopen 
PlatformLinuxOSUbuntuOS Version17.10
Product VersionSlicer 4.9.0 
Target VersionSlicer 4.9.0Fixed in Version 
Summary0004492: crash ChartViews
Description

Slicer will crash on application exit if the ‘Standard Quantitative’ view has been open, whether a plot has been shown or nott. Using Qt5/VTK9 build on Linux.

TagsNo tags attached.

Activities

Davide

Davide

2018-01-23 12:11

developer   ~0015496

Last edited: 2018-01-26 07:13

View 2 revisions

The crash is connected to some wrong reference count in vtkMRLChartViewNode.

The crush occurs only if a chart view node is allocated in the scene, i.e.:

viewNode = slicer.vtkMRMLChartViewNode()
slicer.mrmlScene.AddNode(viewNode)
(MRMLCorePython.vtkMRMLChartViewNode)0x7f2f90ca7530

However it is not clear why the crash occurs in VTK9 (and not in VTK7).

Davide

Davide

2018-02-07 14:55

developer   ~0015512

this is a duplicate of 0004479. l will close.

Issue History

Date Modified Username Field Change
2018-01-17 05:55 Davide New Issue
2018-01-17 05:55 Davide Status new => assigned
2018-01-17 05:55 Davide Assigned To => millerjv
2018-01-17 05:56 Davide Status assigned => new
2018-01-17 06:33 Davide Assigned To millerjv =>
2018-01-23 12:11 Davide Note Added: 0015496
2018-01-26 07:13 Davide Note Edited: 0015496 View Revisions
2018-02-07 14:55 Davide Note Added: 0015512
2018-02-07 14:56 Davide Status new => closed