View Issue Details

IDProjectCategoryView StatusLast Update
0004493Slicer4Module SimpleFilterspublic2018-03-02 16:05
ReporterDavideAssigned Tolassoan 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version17.10
Product VersionSlicer 4.9.0 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0004493: crash In ‘Filtering/Threshold scalar volume’ module
Description

Slicer crashes in Threshold Scalar Volume on ‘Apply’, if ‘Below’ a threshold value is selected. It doesn’t crash if ‘Above’ or ‘Outside’ is chosen. Using Qt5/VTK9 build on Linux.

Tagsvtk-opengl2

Activities

Davide

Davide

2018-01-17 05:59

developer  

lassoan

lassoan

2018-01-17 16:56

developer   ~0015480

I could not reproduce the crash when thresholding is set to ‘below’ on Windows 10 (neither Slicer-4.8.1 nor Slicer-4.9/VTK9/OpenGL2/Qt5).

lassoan

lassoan

2018-01-18 09:25

developer   ~0015481

This seems to be due to KDE adding an extra & character to the GUI. See https://bugs.kde.org/show_bug.cgi?id=337491. Workarounds are described in that bug report (global setting to disable this "feature" or some hacks to block it in an application).

lassoan

lassoan

2018-01-18 10:59

developer   ~0015484

Pushed a fix: https://github.com/Slicer/Slicer/commit/cea9dcfd94bc1b670126c60a06a6950e5ead1c01

It should be available in tomorrow's nightly release. It would be great if somebody could test it.

Issue History

Date Modified Username Field Change
2018-01-17 05:59 Davide New Issue
2018-01-17 05:59 Davide Status new => assigned
2018-01-17 05:59 Davide Assigned To => blowekamp
2018-01-17 05:59 Davide File Added: 5e966693913bc7ff957711135e7bca2e94c67189.png
2018-01-17 05:59 Davide Status assigned => new
2018-01-17 06:33 Davide Assigned To blowekamp =>
2018-01-17 16:56 lassoan Note Added: 0015480
2018-01-18 09:25 lassoan Note Added: 0015481
2018-01-18 10:59 lassoan Assigned To => lassoan
2018-01-18 10:59 lassoan Status new => resolved
2018-01-18 10:59 lassoan Resolution open => fixed
2018-01-18 10:59 lassoan Note Added: 0015484
2018-01-18 10:59 lassoan Fixed in Version => Slicer 4.9.0
2018-01-23 11:21 Davide Status resolved => closed
2018-03-02 16:05 jcfr Tag Attached: vtk-opengl2