View Issue Details

IDProjectCategoryView StatusLast Update
0004498Slicer4Core: Testing Infrastructurepublic2018-03-02 11:03
ReportercriskrossAssigned Tojcfr 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product VersionSlicer 4.8.1 
Target VersionSlicer 4.8.1Fixed in VersionSlicer 4.9.0 
Summary0004498: Nightly build TESTS failing for extensions WITH dependencies to other scriptable modules
Description

Extension tests are failing when having a dependency to another Slicer python extension. See [1] for example, where QuantitativeReporting[2] has a dependency to SlicerDevelopmentToolbox[3] and PETDICOMExtension[4].

[1] http://slicer.cdash.org/testDetails.php?test=8591308&build=1184024
[2] https://github.com/QIICR/QuantitativeReporting
[3] https://github.com/QIICR/SlicerDevelopmentToolbox
[4] https://github.com/QIICR/Slicer-PETDICOMExtension

Similar tests have been failing since January 2017.

For the reference see discussion on https://discourse.slicer.org/t/nightly-build-tests-failing-for-extensions-with-dependencies-to-other-scriptable-modules/1483

TagsNo tags attached.

Activities

fedorov

fedorov

2018-01-23 12:34

developer   ~0015497

Christian, can you please plan to join the Slicer hangout next week to discuss this?

jcfr

jcfr

2018-02-07 01:57

administrator   ~0015510

Closing. The issue was relates to missing dependencies and config file generation in the extensions.

Issue History

Date Modified Username Field Change
2018-01-22 11:15 criskross New Issue
2018-01-22 11:15 criskross Status new => assigned
2018-01-22 11:15 criskross Assigned To => jcfr
2018-01-23 12:34 fedorov Note Added: 0015497
2018-02-07 01:57 jcfr Status assigned => resolved
2018-02-07 01:57 jcfr Resolution open => no change required
2018-02-07 01:57 jcfr Fixed in Version => Slicer 4.9.0
2018-02-07 01:57 jcfr Note Added: 0015510
2018-03-02 11:03 jcfr Status resolved => closed