View Issue Details

IDProjectCategoryView StatusLast Update
0000045Slicer3Base Codepublic2010-03-23 10:54
ReporterpieperAssigned Topieper 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformallOSOS Version
Summary0000045: GE Signa files not supported due to ITK bugs
Description

'Historic' BWH files from GE Signa systems come in GE5 format, and are typically files like I.001, I.002, etc. But these can't be read by ITK currently.

The issues have been reported here:

http://www.itk.org/Bug/bug.php?op=show&bugid=4526&pos=4

http://www.itk.org/Bug/bug.php?op=show&bugid=4527&pos=2

I added code to enable them to vtkITKArchetypeImageSeriesReader.cxx with ifdef for a non-defined symbol USE_ITKGE5READER to keep it from being compiled since it does not work. This can be removed once ITK gets fixed.

TagsNo tags attached.

Activities

pieper

pieper

2007-03-19 10:53

administrator   ~0000053

The ITK bugs have been fixed in the cvs head (thanks to a mysterious retired coder...!) These will propagate to slicer3 with the next release of ITK (version 3.4.

pieper

pieper

2007-03-27 08:51

administrator   ~0000062

Bill Lorenesen fixed these issues in ITK and they will be ready by the next release. (Thanks Bill!).

Issue History

Date Modified Username Field Change
2007-03-02 10:48 pieper New Issue
2007-03-19 10:53 pieper Note Added: 0000053
2007-03-20 06:09 pieper Status new => assigned
2007-03-20 06:09 pieper Assigned To => pieper
2007-03-27 08:51 pieper Note Added: 0000062
2007-03-27 10:29 pieper Resolution open => suspended
2007-03-27 13:27 pieper Status assigned => resolved
2010-03-23 10:54 pieper Status resolved => closed
2010-03-23 10:54 pieper Resolution suspended => fixed