View Issue Details

IDProjectCategoryView StatusLast Update
0004518Slicer4Module Transformspublic2018-03-30 05:06
ReporterfepegarAssigned Topinter 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformmacOSOSSierraOS Version
Product VersionSlicer 4.9.0 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0004518: Slicer crashes when clicking on Transforms color widget
Description

Slicer crashes when clicking on (blank) Transforms color widget

Steps To Reproduce
  1. Open or create a transform
  2. Go to Transforms / Display / Colors
  3. Click on the white rectangle
Additional Information

See the attached screenshot.

TagsNo tags attached.

Activities

fepegar

fepegar

2018-03-10 22:06

reporter  

lassoan

lassoan

2018-03-12 20:11

developer   ~0015548

Thank you for the bug report, it is very useful. Csaba is working on a fix, it should be ready soon.

Until then, a workaround is to grab the slider handle below the white chart area (somewhat tricky, but you should be able to do it) and drag it all the way to the right.

fepegar

fepegar

2018-03-12 20:15

reporter   ~0015549

No, thank you two for all the efficient solutions you always give to our issues.

I managed to see the colors with your workaround.

pinter

pinter

2018-03-13 13:57

developer   ~0015550

The issue has two parts:

  • Crash when clicking in the empty chart view with invalid (0,0) range. This has been fixed in VTK, see PR https://github.com/Kitware/VTK/pull/49
  • The transfer function not showing up because of the invalid (0,0) range. Fixed in CTK, see PR https://github.com/commontk/CTK/pull/789
    When the CTK PR is integrated and Slicer CTK hash updated, then this problem should be gone. Integrating the VTK PR solves a lower level issue, which shouldn't occur if the CTK fix is applied.
fepegar

fepegar

2018-03-14 09:50

reporter   ~0015554

Hi Csaba,

In your PR for VTK they say that you should contribute to theit GitLab repository, instead of on GitHub.

pinter

pinter

2018-03-14 10:05

developer   ~0015556

Yeah I decided I'm not jumping through their hoops of their private (!) gitlab, and as I saw dozens of PRs on github I went for it. I guess I need to register to their gitlab then.

pinter

pinter

2018-03-14 10:09

developer   ~0015557

Fernando, where did you see this message? I cannot see anything in my PR.

fepegar

fepegar

2018-03-14 10:15

reporter   ~0015558

It's included in your own PR message: https://github.com/Kitware/VTK/pull/49#issue-174741708

"Thanks for your interest in contributing to VTK! The GitHub repository
is a mirror provided for convenience, but VTK does not use GitHub pull
requests for contribution. Please see

https://gitlab.kitware.com/vtk/vtk/tree/master/CONTRIBUTING.md

for contribution instructions. GitHub OAuth may be used to sign in."

pinter

pinter

2018-03-14 10:21

developer   ~0015559

https://gitlab.kitware.com/vtk/vtk/merge_requests/4065

pinter

pinter

2018-03-15 11:21

developer   ~0015568

The CTK PR is in, so setting this to resolved, because the symptom in this issue is now gone. Please close if you can confirm. Thanks!

fepegar

fepegar

2018-03-18 17:40

reporter   ~0015573

I can't confirm yet since latest Nightly on macOS 4.9.0-2018-03-16 r27085, and this issue is still present on that version.

pinter

pinter

2018-03-18 20:43

developer   ~0015574

Please wait for one where the fix is expected to be present :) Factories are not very reliable these days...

jcfr

jcfr

2018-03-29 23:30

administrator   ~0015622

Last edited: 2018-03-29 23:30

View 2 revisions

For future reference, corresponding VTK changes were integrated into Slicer in r27113

fepegar

fepegar

2018-03-30 05:06

reporter   ~0015623

Closing since I can't reproduce on macOS r27112.

fepegar

fepegar

2018-03-30 05:06

reporter   ~0015624

Closing since I can't reproduce anymore on macOS r27112.

Issue History

Date Modified Username Field Change
2018-03-10 22:06 fepegar New Issue
2018-03-10 22:06 fepegar Status new => assigned
2018-03-10 22:06 fepegar Assigned To => lassoan
2018-03-10 22:06 fepegar File Added: Screen Shot 2018-03-11 at 03.03.11.png
2018-03-12 20:10 lassoan Assigned To lassoan => pinter
2018-03-12 20:10 lassoan Product Version Slicer 4.8.1 => Slicer 4.9.0
2018-03-12 20:11 lassoan Note Added: 0015548
2018-03-12 20:15 fepegar Note Added: 0015549
2018-03-13 13:57 pinter Note Added: 0015550
2018-03-14 09:50 fepegar Note Added: 0015554
2018-03-14 10:05 pinter Note Added: 0015556
2018-03-14 10:09 pinter Note Added: 0015557
2018-03-14 10:15 fepegar Note Added: 0015558
2018-03-14 10:21 pinter Note Added: 0015559
2018-03-15 11:21 pinter Status assigned => resolved
2018-03-15 11:21 pinter Resolution open => fixed
2018-03-15 11:21 pinter Fixed in Version => Slicer 4.9.0
2018-03-15 11:21 pinter Note Added: 0015568
2018-03-18 17:40 fepegar Note Added: 0015573
2018-03-18 20:43 pinter Note Added: 0015574
2018-03-29 23:30 jcfr Note Added: 0015622
2018-03-29 23:30 jcfr Note Edited: 0015622 View Revisions
2018-03-30 05:06 fepegar Note Added: 0015623
2018-03-30 05:06 fepegar Status resolved => closed
2018-03-30 05:06 fepegar Note Added: 0015624