View Issue Details

IDProjectCategoryView StatusLast Update
0004526Slicer4Core: GUIpublic2018-04-27 10:07
ReporterlassoanAssigned Topinter 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSlicer 4.9.0 
Target VersionSlicer 4.11.0Fixed in VersionSlicer 4.9.0 
Summary0004526: Procedural color node points may be dragged out of visible range
Description

In Colors module, when editing a procedural color node, points may be dragged out of the displayed range and there. Need to switch to another color node and switch back to have the range sliders reset.

How to reproduce:

  • Go to Colors module
  • Select RedGreenBlue colormap
  • Create a copy
  • Adjust visible range slider to see all points
  • Drag the rightmost point towards right side => the point can be moved over the current displayed range (good!) but it gets out of view, we cannot see it anymore, it is not possible to increase the visible range

Workaround: switch to another color node and switch back

Potential solution: update range slider min/max value when mouse release after a drag-and-drop


Another small problem is that displayed range of the colormap is not changed when switching between procedural color nodes.

How to reproduce:

  • Set visible range for RedGreenBlue
  • Switch to dGEMRIC-1.5T node => color chart is all black (because visible range RedGreenBlue is just a very small portion of range of dGEMRIC)

Workaround: adjust visible range sliders manually to see the full range

Potential solution: when switching to a new color node, adjust the visible range to the full range of the colormap

TagsNo tags attached.

Activities

pinter

pinter

2018-04-24 15:55

developer   ~0015679

Pull request issued in CTK: https://github.com/commontk/CTK/pull/800

Once merged, the CTK hash needs to be updated in Slicer, and these issues should be then fixed.

lassoan

lassoan

2018-04-26 16:09

developer   ~0015680

Fix has been integrated into CTK. Csaba, could you update the CTK git hash in Slicer?

pinter

pinter

2018-04-27 10:07

developer   ~0015683

Just did, in this revision https://github.com/Slicer/Slicer/commit/cf2070fc73473fcb6be7f2654bc785a5c5cd7475

Issue History

Date Modified Username Field Change
2018-03-27 23:48 lassoan New Issue
2018-03-27 23:48 lassoan Status new => assigned
2018-03-27 23:48 lassoan Assigned To => pinter
2018-03-31 01:10 jcfr Target Version Slicer 4.9.0 => Slicer 4.11.0
2018-04-24 15:55 pinter Note Added: 0015679
2018-04-26 16:09 lassoan Note Added: 0015680
2018-04-27 10:07 pinter Status assigned => resolved
2018-04-27 10:07 pinter Resolution open => fixed
2018-04-27 10:07 pinter Fixed in Version => Slicer 4.9.0
2018-04-27 10:07 pinter Note Added: 0015683