View Issue Details

IDProjectCategoryView StatusLast Update
0004532Slicer4Core: GUIpublic2018-06-01 11:15
ReporterfepegarAssigned Tolassoan 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformmacOSOSSierraOS Version10.12.6
Product VersionSlicer 4.8.1 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0004532: Slicer crashes when using "Add" or "Subtract" for blending
Description

Slicer crashes when using "Add" or "Subtract" for blending in the slice widgets.

For the record, I'm trying to visualize registration results like this: https://uk.mathworks.com/content/mathworks/uk/en/discovery/image-registration/jcr:content/mainParsys/image_1.adapt.full.high.jpg/1505984376160.jpg

Steps To Reproduce
  1. Download MR head from Sample Data
  2. Set it as background and foreground volume node (happens with different images too)
  3. Set blending mode to Add or Subtract
Additional Information

Log:

[DEBUG][Qt] 02.04.2018 12:52:39 [] (unknown:0) - Session start time .......: 2018-04-02 12:52:39
[DEBUG][Qt] 02.04.2018 12:52:39 [] (unknown:0) - Slicer version ...........: 4.9.0-2018-03-28 (revision 27112) macosx-amd64 - installed
[DEBUG][Qt] 02.04.2018 12:52:39 [] (unknown:0) - Operating system .........: Mac OS X / 10.12.6 / 16G1036 - 64-bit
[DEBUG][Qt] 02.04.2018 12:52:39 [] (unknown:0) - Memory ...................: 8192 MB physical, 2048 MB virtual
[DEBUG][Qt] 02.04.2018 12:52:39 [] (unknown:0) - CPU ......................: GenuineIntel Intel(R) Core(TM) i5-4278U CPU @ 2.60GHz, 2 cores, 4 logical processors
[DEBUG][Qt] 02.04.2018 12:52:39 [] (unknown:0) - Developer mode enabled ...: yes
[DEBUG][Qt] 02.04.2018 12:52:39 [] (unknown:0) - Prefer executable CLI ....: yes
[DEBUG][Qt] 02.04.2018 12:52:39 [] (unknown:0) - Additional module paths ..: (none)
[DEBUG][Python] 02.04.2018 12:52:40 [Python] (/Applications/Slicer.app/Contents/lib/Python/lib/python2.7/site-packages/git/cmd.py:719) - Popen(%s, cwd=%s, universal_newlines=%s, shell=%s)
[DEBUG][Python] 02.04.2018 12:52:40 [Python] (/Applications/Slicer.app/Contents/lib/Python/lib/python2.7/site-packages/git/cmd.py:719) - Popen(%s, cwd=%s, universal_newlines=%s, shell=%s)
[WARNING][Qt] 02.04.2018 12:52:41 [] (unknown:0) - libpng warning: iCCP: known incorrect sRGB profile
[DEBUG][Python] 02.04.2018 12:52:42 [Python] (/Applications/Slicer.app/Contents/lib/Slicer-4.9/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: Annotations
[DEBUG][Python] 02.04.2018 12:52:43 [Python] (/Applications/Slicer.app/Contents/lib/Slicer-4.9/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentEditor
[DEBUG][Python] 02.04.2018 12:52:43 [Python] (/Applications/Slicer.app/Contents/lib/Slicer-4.9/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentStatistics
[INFO][Stream] 02.04.2018 12:52:45 [] (unknown:0) - Loading Slicer RC file [/Users/fernando/.slicerrc.py]
[DEBUG][Qt] 02.04.2018 12:52:46 [] (unknown:0) - Switch to module:  "SubjectBrowser"
[INFO][VTK] 02.04.2018 12:53:16 [vtkMRMLVolumeArchetypeStorageNode (0x7fc2a7b4f380)] (/Volumes/Dashboards/Preview/Slicer-0/Libs/MRML/Core/vtkMRMLVolumeArchetypeStorageNode.cxx:465) - Loaded volume from file: /var/folders/rp/779zzrds13q7z93s151_mv440000gn/T/Slicer/RemoteIO/MR-head.nrrd. Dimensions: 256x256x130. Number of components: 1. Pixel type: short.
[DEBUG][Qt] 02.04.2018 12:53:16 [] (unknown:0) - "Volume" Reader has successfully read the file "/var/folders/rp/779zzrds13q7z93s151_mv440000gn/T/Slicer/RemoteIO/MR-head.nrrd" "[0.22s]"
TagsNo tags attached.

Activities

lassoan

lassoan

2018-06-01 11:05

developer   ~0015868

Crash was probably due to a recent code reorganization. Fixed that and also fixed saturation and alpha channel management in r27222.

Issue History

Date Modified Username Field Change
2018-04-02 07:57 fepegar New Issue
2018-05-31 12:37 lassoan Assigned To => lassoan
2018-05-31 12:37 lassoan Status new => assigned
2018-06-01 11:05 lassoan Status assigned => resolved
2018-06-01 11:05 lassoan Resolution open => fixed
2018-06-01 11:05 lassoan Fixed in Version => Slicer 4.9.0
2018-06-01 11:05 lassoan Note Added: 0015868
2018-06-01 11:05 lassoan Target Version => Slicer 4.9.0
2018-06-01 11:15 fepegar Status resolved => closed