View Issue Details

IDProjectCategoryView StatusLast Update
0004536Slicer4Core: GUIpublic2018-05-19 20:27
ReporterjamesobutlerAssigned Tolassoan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWindows 10 HomeOS Version1709
Product VersionSlicer 4.8.1 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0004536: Closed pop-up dialogs still shown in taskbar thumbnail preview
Description

Closed pop-up dialogs are still visible in the taskbar thumbail preview. This results in confusion about whether the pop-up is actually closed or not.

This includes pop-ups like slicer.util.warningDisplay and the DICOM Browser.

Minimizing and then restoring the main window will reset the thumbnail preview to not include the closed pop-up dialogs.

Steps To Reproduce
  1. Call slicer.util.warningDisplay("Warning")
  2. Close the warning dialog.
  3. Hover over the Slicer icon in the Windows taskbar and hover over the thumbnail preview. (Closed pop-up dialogs will be visible)

  4. Minimize then Restore Slicer main window.
  5. Hover over the Slicer icon in the Windows taskbar and hover over the thumbnail preview. (Closed pop-up dialogs will NOT be visible)
TagsNo tags attached.

Activities

jamesobutler

jamesobutler

2018-05-17 18:40

reporter   ~0015721

Proposed fix in https://github.com/Slicer/Slicer/pull/951

lassoan

lassoan

2018-05-19 19:12

developer   ~0015724

From jamesobutler: "I was able to find an old bug report in Qt's tracker system that is exactly what I was describing. One of the developers punted it saying it was a Windows 10 aero peek issue and suggested the workaround of disabling aero peek for the window (see Qt Windows Extras http://doc.qt.io/qt-5/qtwinextras-overview.html originally introduced in Qt5.2).
QTBUG-48855 https://bugreports.qt.io/browse/QTBUG-48855 "Windows 10: Closed dialogs become visible in live preview when hovering mouse over the application on taskbar"
The only other workaround that I observed that doesn't involve destroying the window is to change the parent of the window because Windows 10 aero peek is evidently showing all child windows of an application even if they are in the hidden state."

lassoan

lassoan

2018-05-19 20:27

developer   ~0015725

The behavior is the same with Paraview (for example: Edit / Find data dialog), MeshMixer (File/Preferences). The problem is that peek shows all hidden but not destroyed windows. Probably it would need to be fixed in Qt or Windows, but the current workaround of destroying messagebox after it is closed is reasonable.
Committed r27195.

Issue History

Date Modified Username Field Change
2018-04-06 12:28 jamesobutler New Issue
2018-04-06 12:28 jamesobutler Steps to Reproduce Updated View Revisions
2018-05-17 18:40 jamesobutler Note Added: 0015721
2018-05-19 19:12 lassoan Note Added: 0015724
2018-05-19 20:27 lassoan Assigned To => lassoan
2018-05-19 20:27 lassoan Status new => resolved
2018-05-19 20:27 lassoan Resolution open => fixed
2018-05-19 20:27 lassoan Fixed in Version => Slicer 4.9.0
2018-05-19 20:27 lassoan Note Added: 0015725