View Issue Details

IDProjectCategoryView StatusLast Update
0004542Slicer4Module SceneViewspublic2018-09-13 11:46
ReporterspujolAssigned Tolassoan 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSlicer 4.9.0 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0004542: Scene Views crashes Slicer
Description

I loaded the .mrb file 'RegLib_C01.mrb' from the Registration Case library

https://www.slicer.org/wiki/Documentation/4.8/Registration/RegistrationLibrary

Slicer crashes when I try to visualize the Scene Views of the .mrb file

Additional Information

MacOSX Version 10.12.6

Slicer4.9 nightly build

TagsNo tags attached.

Relationships

has duplicate 0004508 closedlassoan Qt5: Update SceneView to work with QtWebEngine 
related to 0004608 newjcfr Saving a new scene view - Data improperly listed as modified 

Activities

lassoan

lassoan

2018-07-17 01:15

developer   ~0015916

Pull request submitted with a fix (switch to native Qt widget implementation - QTableWidget):

https://github.com/Slicer/Slicer/pull/991

lassoan

lassoan

2018-07-17 09:46

developer   ~0015917

The fix resolved these failing tests:

611 - py_AtlasTests (Failed)
614 - py_KneeAtlasTest (Failed)
lassoan

lassoan

2018-07-17 21:41

developer   ~0015919

Fixed in r27283.

spujol

spujol

2018-09-12 14:07

developer   ~0015995

I could restore the scene views of RegLib_C01.mrb with 4.9.0-2018-09-10 r27399 on MacOS.

I created a new scene with a nrrd file and a vtk model, and generated two scene views.
https://www.dropbox.com/s/fcay5heqditmu1i/TestScene.zip?dl=0

I closed the scene and re-opened it to create a third scene view without doing any processing of the data.

When I try to save the scene, the model Skin.vtk is checked as if it had been modified.



lassoan

lassoan

2018-09-12 14:20

developer   ~0015996

Thank you for reporting this. I could reproduce what you described (Skin.vtk is marked as modified). Since it is not related to the original problem described and solved in this bug report, would you mind creating a new bug report for this? You can refer to this bug report, so you don't need to re-upload screenshot, etc.

spujol

spujol

2018-09-12 15:10

developer   ~0015997

Sure, no problem

jcfr

jcfr

2018-09-13 11:42

administrator   ~0016008

You can refer to this bug report, so you don't need to re-upload screenshot, etc.

I just realized what https://issues.slicer.org/view.php?id=4608 was about. I will re-open it adding a more detailed description.

Issue History

Date Modified Username Field Change
2018-04-16 16:56 spujol New Issue
2018-04-16 16:56 spujol Status new => assigned
2018-04-16 16:56 spujol Assigned To => nicole
2018-07-17 01:15 lassoan Note Added: 0015916
2018-07-17 01:21 lassoan Relationship added has duplicate 0004508
2018-07-17 09:46 lassoan Note Added: 0015917
2018-07-17 21:41 lassoan Assigned To nicole => lassoan
2018-07-17 21:41 lassoan Status assigned => resolved
2018-07-17 21:41 lassoan Resolution open => fixed
2018-07-17 21:41 lassoan Fixed in Version => Slicer 4.9.0
2018-07-17 21:41 lassoan Note Added: 0015919
2018-09-12 14:07 spujol File Added: Screenshot 2018-09-12 14.00.20.png
2018-09-12 14:07 spujol Note Added: 0015995
2018-09-12 14:20 lassoan Note Added: 0015996
2018-09-12 15:10 spujol Note Added: 0015997
2018-09-13 11:42 jcfr Note Added: 0016008
2018-09-13 11:46 jcfr Relationship added related to 0004608