View Issue Details

IDProjectCategoryView StatusLast Update
0004544Slicer4Core: Base Codepublic2018-10-16 05:38
ReporterdevakumarAssigned Tojcfr 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSlicer 4.8.1 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0004544: Unable to launch Extension Manager in Slicer-4.9.0-2018-04-19
Description

[devakumar@ipl Slicer-4.9.0-2018-04-19-linux-amd64]$ ./Slicer
libpng warning: iCCP: known incorrect sRGB profile
Switch to module: "Welcome"
An OpenGL Core Profile was requested, but it is not supported on the current platform. Falling back to a non-Core profile. Note that this might cause rendering issues.
[0421/161536.960341:WARNING:stack_trace_posix.cc(648)] Failed to open file: /tmp/ffi2KBUJ6 (deleted)
Error: No such file or directory
Qt WebEngine ICU data not found at /opt/qt/5.10.1/gcc_64/resources. Trying parent directory...
Qt WebEngine ICU data not found at /opt/qt/5.10.1/gcc_64. Trying application directory...
Qt WebEngine ICU data not found at /home/devakumar/Documents/software/slicer/2018/April/Slicer-4.9.0-2018-04-19-linux-amd64/libexec. Trying fallback directory... The application MAY NOT work.
Path override failed for key base::DIR_QT_LIBRARY_DATA and path '/home/devakumar/.QtWebEngineProcess'
Installed Qt WebEngine locales directory not found at location /opt/qt/5.10.1/gcc_64/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/devakumar/Documents/software/slicer/2018/April/Slicer-4.9.0-2018-04-19-linux-amd64/libexec/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
Path override failed for key ui::DIR_LOCALES and path '/home/devakumar/.QtWebEngineProcess'
[0421/161537.251724:ERROR:icu_util.cc(179)] Invalid file descriptor to ICU data received.
[0421/161537.251857:FATAL:content_main_runner.cc(611)] Check failed: base::i18n::InitializeICU().
#0 0x7f0a2fc8f0a5 <unknown>
0000001 0x7f0a2fca4eca <unknown>
0000002 0x7f0a2fc596bb <unknown>
0000003 0x7f0a30ba7703 <unknown>
0000004 0x7f0a2fc58d81 <unknown>
0000005 0x7f0a2ea1cc1c QtWebEngine::processMain()
0000006 0x0000004009f3 <unknown>
0000007 0x7f0a2ae65c05 __libc_start_main
0000008 0x000000400a2f <unknown>

TagsNo tags attached.

Relationships

related to 0004639 assignedjcfr Fix WebEngine warning "No URLRequestContext for NSS HTTP handler" 
related to 0004640 assignedjcfr WebEngine: Fix "An OpenGL Core Profile was requested, but it is not supported on the current platform" 
related to 0004638 resolvedjcfr Fix Qt WebEngine locales and ICU data not found when opening extension manager on Linux 

Activities

inorton

inorton

2018-05-03 13:32

developer   ~0015692

Temporary work-around:

root@kali:~/Downloads/Slicer-4.9.0-2018-05-02-linux-amd64# cp resources/* libexec/
root@kali:~/Downloads/Slicer-4.9.0-2018-05-02-linux-amd64#

inorton

inorton

2018-05-03 13:40

developer   ~0015693

Last edited: 2018-05-03 13:41

View 3 revisions

According to the documentation (https://doc.qt.io/qt-5.10/qtwebengine-deploying.html), it is supposed to search in

On Linux and Windows: the resources directory in the directory specified by QLibraryInfo::location(QLibraryInfo::DataPath)

which is:

>>> l = qt.QLibraryInfo
>>> l.location(l.DataPath)
u'/root/Downloads/Slicer-4.9.0-2018-05-02-linux-amd64'

But maybe a different location is hard-coded in QWebEngineProcess, and it doesn't pick up the main QApp setting because it is launched separately?

some related discussion: https://github.com/probonopd/linuxdeployqt/issues/57

inorton

inorton

2018-05-03 14:00

developer   ~0015694

Another solution is to add a file called qt.conf in libexec with the contents:

[Paths]
Prefix=../resources

from: https://forum.qt.io/topic/52666/error-resource_bundle-cc-639-failed-to-load-qtwebengine_resources-pak/3

inorton

inorton

2018-05-03 14:25

developer   ~0015696

Here's the proper upstream bug and fix: https://codereview.qt-project.org/#/c/220734/

Not available until 5.11 though, so qt.conf temporary solution proposed here:

https://github.com/Slicer/Slicer/pull/944

jcfr

jcfr

2018-05-09 17:37

administrator   ~0015705

Thanks to @inorton, workaround implemented in r27179
See http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=27179

devakumar

devakumar

2018-05-09 18:13

reporter   ~0015706

Thank you jcfr and norton for fixing the bug. It is working now. I could install the extensions without problem. But I noticed some messages in the command window which I am pasting below. I think that should not be a problem. The modified code could finally QtWebEngineProcess path.

[devakumar@ipl Slicer-4.9.0-2018-05-08-linux-amd64]$ ./Slicer
libpng warning: iCCP: known incorrect sRGB profile
Switch to module: "Welcome"
An OpenGL Core Profile was requested, but it is not supported on the current platform. Falling back to a non-Core profile. Note that this might cause rendering issues.
[0510/025055.729331:WARNING:stack_trace_posix.cc(648)] Failed to open file: /tmp/ffiw5HDkC (deleted)
Error: No such file or directory
Qt WebEngine ICU data not found at /home/devakumar/Documents/software/slicer/2018/May/Slicer-4.9.0-2018-05-08-linux-amd64/resources/resources. Trying parent directory...
Installed Qt WebEngine locales directory not found at location /home/devakumar/Documents/software/slicer/2018/May/Slicer-4.9.0-2018-05-08-linux-amd64/resources/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/devakumar/Documents/software/slicer/2018/May/Slicer-4.9.0-2018-05-08-linux-amd64/libexec/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
Path override failed for key ui::DIR_LOCALES and path '/home/devakumar/.QtWebEngineProcess'
Qt WebEngine resources not found at /home/devakumar/Documents/software/slicer/2018/May/Slicer-4.9.0-2018-05-08-linux-amd64/resources/resources. Trying parent directory...
[0510/025056.203696:WARNING:resource_bundle_qt.cpp(115)] locale_file_path.empty() for locale
[4024:4051:0510/025104.723475:ERROR:nss_ocsp.cc(613)] No URLRequestContext for NSS HTTP handler. host: ocsp.digicert.com
[4024:4051:0510/025104.723515:ERROR:nss_ocsp.cc(613)] No URLRequestContext for NSS HTTP handler. host: ocsp.digicert.com
[4024:4051:0510/025104.723582:ERROR:nss_ocsp.cc(613)] No URLRequestContext for NSS HTTP handler. host: crl4.digicert.com
[4024:4051:0510/025104.729200:ERROR:nss_ocsp.cc(613)] No URLRequestContext for NSS HTTP handler. host: ocsp.digicert.com
[4024:4051:0510/025104.729293:ERROR:nss_ocsp.cc(613)] No URLRequestContext for NSS HTTP handler. host: ocsp.digicert.com
[4024:4051:0510/025104.729374:ERROR:nss_ocsp.cc(613)] No URLRequestContext for NSS HTTP handler. host: crl4.digicert.com
"Retrieving extension metadata [ extensionId: 224045]"
"Downloading extension [ itemId: 358986]"

jcfr

jcfr

2018-10-16 05:37

administrator   ~0016141

Last edited: 2018-10-16 05:38

View 2 revisions

@devakumar The different warnings and errors are now tracked in dedicated issues (see related issues above)

Issue History

Date Modified Username Field Change
2018-04-21 07:02 devakumar New Issue
2018-04-21 07:02 devakumar Status new => assigned
2018-04-21 07:02 devakumar Assigned To => jcfr
2018-05-03 13:32 inorton Note Added: 0015692
2018-05-03 13:40 inorton Note Added: 0015693
2018-05-03 13:40 inorton Note Edited: 0015693 View Revisions
2018-05-03 13:41 inorton Note Edited: 0015693 View Revisions
2018-05-03 14:00 inorton Note Added: 0015694
2018-05-03 14:25 inorton Note Added: 0015696
2018-05-09 17:37 jcfr Status assigned => resolved
2018-05-09 17:37 jcfr Resolution open => fixed
2018-05-09 17:37 jcfr Note Added: 0015705
2018-05-09 17:37 jcfr Fixed in Version => Slicer 4.9.0
2018-05-09 18:13 devakumar Note Added: 0015706
2018-10-16 05:10 jcfr Relationship added related to 0004638
2018-10-16 05:32 jcfr Relationship added related to 0004639
2018-10-16 05:37 jcfr Relationship added related to 0004640
2018-10-16 05:37 jcfr Note Added: 0016141
2018-10-16 05:38 jcfr Note Edited: 0016141 View Revisions