View Issue Details

IDProjectCategoryView StatusLast Update
0004546Slicer4Core: Usabilitypublic2018-06-04 08:49
Reporternick_slizerAssigned Tolassoan 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0004546: Dot (".") in volume name leads to wrong variable name, wrong modified status, and suffix doubling
Description

I could not reproduce 0003890 as stated.

A simpler and basic problem it seems (?): if a volume name contains a "." --- in addition to the "." of the suffix --- then it cannot be loaded correctly (at least under Windows). In particular, the status is "Modified" and ".nnrd" is doubled in VolumeArchetypeStorage.

Work-around: don't use "." in file names (although the Segmentation code does so with success as far as I can see).

Steps To Reproduce

1) load MRHead
2) save MRHead under a different name "MR.head.nrrd". Note the extra dot.
3) close "Save data"
4) close scence
5) add "MR.head.nrrd"
6) name will be reported in error as "MR.Head.nrrd" in Data section and the volume is marked Modified. Also, suffix doubling of ".nrrd" is noted in MRML file.

With name "MRhead.nrrd" instead, the volume will be named "MRhead" in Data section when added and it will not be modified -- expected behavior.

Additional Information

Version: 4.9.0-2018-04-06 r27131. Windows 10.

TagsNo tags attached.

Relationships

related to 0003890 acknowledgedpieper Renaming node in the scene changes the filename in the storage node 

Activities

pieper

pieper

2018-04-26 17:21

administrator   ~0015682

I was not able to reproduce this on mac or windows (with april 23 build)

Maybe I'm not understanding the steps exactly. Here's what I did:

1) download MRHead from SampleData
2) rename to MR.Head
3) all scene files to temp dir

File name is correct as MR.Head.nrrd. MRML scene file saves and reloads correctly. No doubling of the extension is seen either on the file system or inside the MRML file.

Am I messing a step?

nick_slizer

nick_slizer

2018-04-27 11:46

reporter   ~0015684

I think you're missing a "close scene" --- here's an easier way to reproduce (now using April 23 version on Windows):

  • make two copies of the mrhead file (use the file browser, OS level) and name them "MR.head.nrrd" and "MRhead.nrrd" (where ".nrrd" is the file extension)
  • start Slicer, "add data" and select one or the other file, then "save"
  • then you'll see either of two situations (pics enclosed) depending on that extra dot -- and the extra dot case shows two of the errors (variable name and modified status)
  • and if you save the scene you'll see doubling of file extension in the extra dot case, not in the regular case


CaptureDOT.PNG (15,695 bytes)
CaptureDOT.PNG (15,695 bytes)
CaptureNODOT.PNG (16,370 bytes)
CaptureNODOT.PNG (16,370 bytes)
lassoan

lassoan

2018-05-29 09:53

developer   ~0015763

Volume storage node was not initialized correctly and therefore failed to strip file extension correctly. Fixed in r27210.

pieper

pieper

2018-05-29 10:22

administrator   ~0015764

Thanks Andras!

Issue History

Date Modified Username Field Change
2018-04-26 13:06 nick_slizer New Issue
2018-04-26 13:06 nick_slizer Status new => assigned
2018-04-26 13:06 nick_slizer Assigned To => pieper
2018-04-26 13:43 nick_slizer Steps to Reproduce Updated View Revisions
2018-04-26 16:57 pieper Relationship added related to 0003890
2018-04-26 17:21 pieper Note Added: 0015682
2018-04-27 11:46 nick_slizer File Added: CaptureDOT.PNG
2018-04-27 11:46 nick_slizer File Added: CaptureNODOT.PNG
2018-04-27 11:46 nick_slizer Note Added: 0015684
2018-05-29 09:53 lassoan Assigned To pieper => lassoan
2018-05-29 09:53 lassoan Status assigned => resolved
2018-05-29 09:53 lassoan Resolution open => fixed
2018-05-29 09:53 lassoan Fixed in Version => Slicer 4.9.0
2018-05-29 09:53 lassoan Note Added: 0015763
2018-05-29 10:22 pieper Note Added: 0015764
2018-06-04 08:49 pieper Status resolved => closed