View Issue Details

IDProjectCategoryView StatusLast Update
0004553Slicer4Core: Packagingpublic2018-05-23 11:11
ReportercquammenAssigned Tojcfr 
PrioritylowSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product VersionSlicer 4.9.0 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0004553: SlicerPython does not launch with packaged SlicerPythonLauncherSettings.ini configuration
Description

If I add the path of SlicerPython to my PATH environment variable and try to run

SlicerPython

I get the error

error: Application does NOT exists [/Applications/Slicer.app/Contents/bin/bin/python-real]

This occurs on Linux, Mac, and Windows.

To fix this, I had to modify the SlicerPythonLauncherSettings.ini file that is included in the Slicer packages on. Under the [Application] section, I modified the path entry from

path=<APPLAUNCHER_DIR>/bin/python-real

to

path=<APPLAUNCHER_DIR>/../bin/python-real

This looks like an easy fix to the source code to an experiences Slicer developer, but a cursory search for where this .ini file is set up made it just beyond my reach as a Slicer user.

TagsNo tags attached.

Relationships

related to 0004556 closedjcfr PYTHONPATH in SlicerPythonLauncherSettings.ini needs additional paths to import vtk in SlicerPython 
related to 0004554 closedjcfr rpath not set for macOS binaries in 4.9.0 

Activities

jcfr

jcfr

2018-05-15 17:53

administrator   ~0015712

Last edited: 2018-05-15 17:54

View 3 revisions

Thanks for the detailed report.

The SlicerPython launcher is configured using this external project step

Then, I suggest to update this line with either ../${Slicer_BIN_DIR} or preferably .

This is required because the launcher SlicerPython is installed in the same directory as the python executable.

For reference, the install rule for the SlicerPython launcher can be found in CMake/SlicerBlockInstallPython.cmake

cquammen

cquammen

2018-05-15 17:57

developer   ~0015713

Thanks, JC. I will update the suggested line and submit a change.

jcfr

jcfr

2018-05-15 18:32

administrator   ~0015714

Fixed was proposed in PR https://github.com/Slicer/Slicer/pull/946

and integrated in r27189
See http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=27189

Issue History

Date Modified Username Field Change
2018-05-15 10:08 cquammen New Issue
2018-05-15 10:08 cquammen Status new => assigned
2018-05-15 10:08 cquammen Assigned To => jcfr
2018-05-15 17:53 jcfr Note Added: 0015712
2018-05-15 17:54 jcfr Note Edited: 0015712 View Revisions
2018-05-15 17:54 jcfr Note Edited: 0015712 View Revisions
2018-05-15 17:57 cquammen Note Added: 0015713
2018-05-15 18:32 jcfr Status assigned => resolved
2018-05-15 18:32 jcfr Resolution open => fixed
2018-05-15 18:32 jcfr Fixed in Version => Slicer 4.9.0
2018-05-15 18:32 jcfr Note Added: 0015714
2018-05-23 04:13 jcfr Relationship added related to 0004556
2018-05-23 04:13 jcfr Relationship added related to 0004554
2018-05-23 11:11 jcfr Status resolved => closed