View Issue Details

IDProjectCategoryView StatusLast Update
0004559Slicer4Extension: (Any extensions)public2018-07-09 06:22
ReporterDavideAssigned Tosjh267 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionopen 
Platform OSUbuntuOS Version18.04
Product VersionSlicer 4.9.0 
Target VersionSlicer 4.9.0Fixed in Version 
Summary0004559: crash when opening extension manager in linux
Description

Slicer binaries (downloaded today 22/05/2018 from http://slicer.cdash.org/index.php?project=SlicerPreview) crash if opening the extension manager.

It seems that the extension manager is trying to open this folder /tmp/.gldA8xTd but has no permission. Running the binaries with sudo fix the issue.

Here is the log:
An OpenGL Core Profile was requested, but it is not supported on the current platform. Falling back to a non-Core profile. Note that this might cause rendering issues.
[0522/095550.243723:WARNING:stack_trace_posix.cc(648)] Failed to open file: /tmp/.gldA8xTd (deleted)
Error: No such file or directory
[0522/095550.243990:WARNING:stack_trace_posix.cc(648)] Failed to open file: /home/davide/#4194344 (deleted)
Error: No such file or directory
Could not find QtWebEngineProcess
[23745:23745:0522/095550.533467:FATAL:zygote_host_impl_linux.cc(182)] Check failed: ReceiveFixedMessage(fds[0], kZygoteBootMessage, sizeof(kZygoteBootMessage), &boot_pid).
#0 0x7f7c914ac0a5 <unknown>
0000001 0x7f7c914c1eca <unknown>
0000002 0x7f7c90b04fc3 <unknown>
0000003 0x7f7c90b03c3b <unknown>
0000004 0x7f7c90b04219 <unknown>
0000005 0x7f7c9074793a <unknown>
0000006 0x7f7c9074ce76 <unknown>
0000007 0x7f7c9026a600 <unknown>
0000008 0x7f7c9026bb25 <unknown>
0000009 0x7f7c902000c6 QtWebEngineCore::BrowserContextAdapter::BrowserContextAdapter()
0000010 0x7f7c964226be QWebEngineProfile::QWebEngineProfile()
0000011 0x7f7c98c74551 qSlicerWebWidgetPrivate::init()
0000012 0x7f7c98c75e36 qSlicerExtensionsInstallWidget::qSlicerExtensionsInstallWidget()
0000013 0x7f7c98c8b9d5 Ui_qSlicerExtensionsManagerWidget::setupUi()
0000014 0x7f7c98c8a598 qSlicerExtensionsManagerWidgetPrivate::init()
0000015 0x7f7c98c8b68e qSlicerExtensionsManagerWidget::qSlicerExtensionsManagerWidget()
0000016 0x7f7c98c87c08 qSlicerExtensionsManagerDialogPrivate::init()
0000017 0x7f7c98c8851e qSlicerExtensionsManagerDialog::qSlicerExtensionsManagerDialog()
0000018 0x7f7c98c11157 qSlicerApplication::openExtensionsManagerDialog()
0000019 0x7f7c99751dd5 qSlicerAppMainWindow::qt_metacall()
0000020 0x7f7c7b01b394 QMetaObject::activate()
0000021 0x7f7c7bdfd582 QAction::triggered()
0000022 0x7f7c7bdffa80 QAction::activate()
0000023 0x7f7c7bef5e10 <unknown>
0000024 0x7f7c7bef5f25 QAbstractButton::mouseReleaseEvent()
0000025 0x7f7c7bfc6cda QToolButton::mouseReleaseEvent()
0000026 0x7f7c7be40018 QWidget::event()
0000027 0x7f7c7bfc6da9 QToolButton::event()
0000028 0x7f7c7be0363c QApplicationPrivate::notify_helper()
0000029 0x7f7c7be0b363 QApplication::notify()
0000030 0x7f7c98c10a0c qSlicerApplication::notify()
0000031 0x7f7c7aff0028 QCoreApplication::notifyInternal2()
0000032 0x7f7c7be09fcf QApplicationPrivate::sendMouseEvent()
0000033 0x7f7c7be59b3d <unknown>
0000034 0x7f7c7be5c453 <unknown>
0000035 0x7f7c7be0363c QApplicationPrivate::notify_helper()
0000036 0x7f7c7be0a987 QApplication::notify()
0000037 0x7f7c98c10a0c qSlicerApplication::notify()
0000038 0x7f7c7aff0028 QCoreApplication::notifyInternal2()
0000039 0x7f7c7b5f3300 QGuiApplicationPrivate::processMouseEvent()
0000040 0x7f7c7b5f50d5 QGuiApplicationPrivate::processWindowSystemEvent()
0000041 0x7f7c7b5d082b QWindowSystemInterface::sendWindowSystemEvents()
0000042 0x7f7c66272b8b <unknown>
0000043 0x7f7c7afee89a QEventLoop::exec()
0000044 0x7f7c7aff7424 QCoreApplication::exec()
0000045 0x0000004043a6 main
0000046 0x7f7c70665b97 __libc_start_main
0000047 0x0000004044a0 <unknown>

Received signal 6
#0 0x7f7c914ac0a5 <unknown>
0000001 0x7f7c901ed141 <unknown>
0000002 0x7f7c914ac43d <unknown>
0000003 0x7f7c85855890 <unknown>
0000004 0x7f7c70682e97 gsignal
0000005 0x7f7c70684801 abort
0000006 0x7f7c914abdc5 <unknown>
0000007 0x7f7c914c21ed <unknown>
0000008 0x7f7c90b04fc3 <unknown>
0000009 0x7f7c90b03c3b <unknown>
0000010 0x7f7c90b04219 <unknown>
0000011 0x7f7c9074793a <unknown>
0000012 0x7f7c9074ce76 <unknown>
0000013 0x7f7c9026a600 <unknown>
0000014 0x7f7c9026bb25 <unknown>
0000015 0x7f7c902000c6 QtWebEngineCore::BrowserContextAdapter::BrowserContextAdapter()
0000016 0x7f7c964226be QWebEngineProfile::QWebEngineProfile()
0000017 0x7f7c98c74551 qSlicerWebWidgetPrivate::init()
0000018 0x7f7c98c75e36 qSlicerExtensionsInstallWidget::qSlicerExtensionsInstallWidget()
0000019 0x7f7c98c8b9d5 Ui_qSlicerExtensionsManagerWidget::setupUi()
0000020 0x7f7c98c8a598 qSlicerExtensionsManagerWidgetPrivate::init()
0000021 0x7f7c98c8b68e qSlicerExtensionsManagerWidget::qSlicerExtensionsManagerWidget()
0000022 0x7f7c98c87c08 qSlicerExtensionsManagerDialogPrivate::init()
0000023 0x7f7c98c8851e qSlicerExtensionsManagerDialog::qSlicerExtensionsManagerDialog()
0000024 0x7f7c98c11157 qSlicerApplication::openExtensionsManagerDialog()
0000025 0x7f7c99751dd5 qSlicerAppMainWindow::qt_metacall()
0000026 0x7f7c7b01b394 QMetaObject::activate()
0000027 0x7f7c7bdfd582 QAction::triggered()
0000028 0x7f7c7bdffa80 QAction::activate()
0000029 0x7f7c7bef5e10 <unknown>
0000030 0x7f7c7bef5f25 QAbstractButton::mouseReleaseEvent()
0000031 0x7f7c7bfc6cda QToolButton::mouseReleaseEvent()
0000032 0x7f7c7be40018 QWidget::event()
0000033 0x7f7c7bfc6da9 QToolButton::event()
0000034 0x7f7c7be0363c QApplicationPrivate::notify_helper()
0000035 0x7f7c7be0b363 QApplication::notify()
0000036 0x7f7c98c10a0c qSlicerApplication::notify()
0000037 0x7f7c7aff0028 QCoreApplication::notifyInternal2()
0000038 0x7f7c7be09fcf QApplicationPrivate::sendMouseEvent()
0000039 0x7f7c7be59b3d <unknown>
0000040 0x7f7c7be5c453 <unknown>
0000041 0x7f7c7be0363c QApplicationPrivate::notify_helper()
0000042 0x7f7c7be0a987 QApplication::notify()
0000043 0x7f7c98c10a0c qSlicerApplication::notify()
0000044 0x7f7c7aff0028 QCoreApplication::notifyInternal2()
0000045 0x7f7c7b5f3300 QGuiApplicationPrivate::processMouseEvent()
0000046 0x7f7c7b5f50d5 QGuiApplicationPrivate::processWindowSystemEvent()
0000047 0x7f7c7b5d082b QWindowSystemInterface::sendWindowSystemEvents()
0000048 0x7f7c66272b8b <unknown>
0000049 0x7f7c7afee89a QEventLoop::exec()
0000050 0x7f7c7aff7424 QCoreApplication::exec()
0000051 0x0000004043a6 main
0000052 0x7f7c70665b97 __libc_start_main
0000053 0x0000004044a0 <unknown>

TagsNo tags attached.

Activities

sjh267

sjh267

2018-06-06 15:16

administrator   ~0015873

This appears to be a linux/Qt issue. Have found highly similar problems: https://github.com/qutebrowser/qutebrowser/issues/3662

This fix would be to revert the dashboard machine to 5.10.0 from 5.10.1. I have tested a 5.10.0 build and it works

@jcfr

jcfr

jcfr

2018-06-06 15:45

administrator   ~0015874

Last edited: 2018-06-06 15:45

View 2 revisions

Thanks for the update. Could you check if the issue is addressed using Qt 5.11 ?

This could be updating the docker image we used to build linux installers: https://github.com/Slicer/SlicerBuildEnvironment/tree/master/Docker/qt5-centos7

For an example of use of such image, see https://github.com/Slicer/SlicerBuildEnvironment#configure-build-and-package-slicer-for-linux

sjh267

sjh267

2018-06-06 15:51

administrator   ~0015875

The issue should be addressed in 5.11: https://bugreports.qt.io/browse/QTBUG-67023

Davide

Davide

2018-07-09 06:22

developer   ~0015911

I confirm that this has been fixed. Thanks!

Issue History

Date Modified Username Field Change
2018-05-22 04:19 Davide New Issue
2018-05-29 12:03 jcfr Assigned To => sjh267
2018-05-29 12:03 jcfr Status new => assigned
2018-06-06 15:16 sjh267 Note Added: 0015873
2018-06-06 15:45 jcfr Note Added: 0015874
2018-06-06 15:45 jcfr Note Edited: 0015874 View Revisions
2018-06-06 15:51 sjh267 Note Added: 0015875
2018-07-09 06:22 Davide Note Added: 0015911
2018-07-09 06:22 Davide Status assigned => resolved