View Issue Details

IDProjectCategoryView StatusLast Update
0004573Slicer4Core: Extensionspublic2018-10-16 07:49
Reporterji.bok216Assigned Tojcfr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformPCOSWindows 10OS Version
Product VersionSlicer 4.6.0 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0004573: Unable to Download Extensions
Description

I tried to install extensions with Extensions Manager, but as soon as I click "INSTALL", it says:
"Retrieving extension metadata [extensionID:133951]"
"Downloading extension [ itemID: 259227]"
"Failed downloading: http://slicer.kitware.com/midas3/download?items=259227";.
The download fails with every single extension available in the Extensions Manager.

Then, I tried to download extensions through the Slicer extension catalog, http://slicer.kitware.com/midas3/slicerappstore. Even after typing the revision number, the page errors and says:
"An error occurred
The system has encountered the following error:
Unable to find file on the disk
In /projects/src/Midas3/core/controllers/components/DownloadBitstreamComponent.php, line: 45
At 17:04:48 2018-06-14

Please notify your administrator with this information."

Steps To Reproduce

With Extension Manager

  1. Open "Extensions Manager"
  2. Click the "INSTALL" button for any of the extensions

With Extension Catalog

  1. Go to the catalog website, http://slicer.kitware.com/midas3/slicerappstore
  2. Type in the revision number "25441" on Windows 64 bit
  3. Click the "DOWNLOAD" button for any extensions
Additional Information

Slicer 4.6.0 r25441

TagsNo tags attached.

Activities

ji.bok216

ji.bok216

2018-06-14 17:26

reporter  

extensionManagerError.png (390,287 bytes)
extensionManagerError.png (390,287 bytes)
jcfr

jcfr

2018-10-16 07:49

administrator   ~0016150

Since 25441 corresponds to Slicer 4.6.0, associated extensions where deleted. Instead the extensions packages associated with Slicer 4.6.2 are available.

See http://slicer.kitware.com/midas3/slicerappstore/?os=win&arch=amd64&revision=%2025516&category=&search=&layout=layout and https://www.slicer.org/wiki/Release_Details#Slicer_4.6

Issue History

Date Modified Username Field Change
2018-06-14 17:26 ji.bok216 New Issue
2018-06-14 17:26 ji.bok216 Status new => assigned
2018-06-14 17:26 ji.bok216 Assigned To => jcfr
2018-06-14 17:26 ji.bok216 File Added: extensionCatalogyError.png
2018-06-14 17:26 ji.bok216 File Added: extensionManagerError.png
2018-10-16 07:49 jcfr Status assigned => resolved
2018-10-16 07:49 jcfr Resolution open => no change required
2018-10-16 07:49 jcfr Fixed in Version => Slicer 4.9.0
2018-10-16 07:49 jcfr Note Added: 0016150