View Issue Details

IDProjectCategoryView StatusLast Update
0004583Slicer4Core: Building (CMake, Superbuild)public2018-10-16 07:18
ReporterwulcAssigned Tojcfr 
PriorityhighSeveritytrivialReproducibilityalways
Status resolvedResolutionduplicate 
PlatformVS2015 64 professional pack3OSwindows 64 homeOS Version10
Product VersionSlicer 4.8.1 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0004583: Cmake report error
Description

When I build the slicer According to https://www.slicer.org/wiki/Documentation/Nightly/Developers/Build_Instructions#Windows? It always make an error , I thought many ways, but it do not work well.

Steps To Reproduce

1,open "cmake3.8.2" gui ,at the "where is the source code", click the "Browse Source..," button, and select the Slicer directory?like: D:\MyProject\Slicer).
2,At the "where to build the binaries" ,select a directory where you want to build in (like:D:\MyProject\build)
3,press and release the "Configure" button, the error show.

Additional Information

I used Qt5.10.1 as the “https://www.slicer.org/wiki/Documentation/Nightly/Developers/Build_Instructions#Windows” page specified?
Qt:
Qt5 recommended and officially supported. Download qt-unified-windows-x86-online.exe and install Qt along with qtscript and qtwebengine components. For more details, read step-by-step guide.
Qt 4: will still work until Slicer-4.10 but not officially supported. See details here.

Tested and recommended build environment
VS2015
Make sure you enable installation of component Programming languages / Visual C++ / Common Tools for Visual C++ 2015 (in some distributions, this option is not enabled by default)
Installation of Cumulative Servicing Release for Microsoft Visual Studio 2015 Update 3 (KB3165756) is required on some older VS2015 distributions
Qt 5.10
CMake >= 3.3.1

TagsNo tags attached.

Relationships

duplicate of 0004584 assignedjcfr Cmake report error 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-07-19 04:38 wulc New Issue
2018-07-19 04:38 wulc Status new => assigned
2018-07-19 04:38 wulc Assigned To => jcfr
2018-10-16 07:18 jcfr Status assigned => resolved
2018-10-16 07:18 jcfr Resolution open => duplicate
2018-10-16 07:18 jcfr Fixed in Version => Slicer 4.9.0
2018-10-16 07:18 jcfr Relationship added duplicate of 0004584