View Issue Details

IDProjectCategoryView StatusLast Update
0004587Slicer4Core: Base Codepublic2018-07-26 13:51
ReporterinortonAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0004587: Should --additional-module-paths fix-up relative paths?
Description

In directory:

macbook-pro-2:SlicerJupyter-s5 inorton$ pwd
/opt/bld/SlicerJupyter-s5

The following doesn't work -- DSO fails to load (see additional information)

/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/MacOS/Slicer --additional-module-paths inner-build/lib/Slicer-4.9/qt-loadable-modules/ --verbose-module-discovery

The following works, giving full path to --additional-module-paths

/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/MacOS/Slicer --additional-module-paths /opt/bld/SlicerJupyter-s5/inner-build/lib/Slicer-4.9/qt-loadable-modules/ --verbose-module-discovery
Additional Information

Fails here:

* thread <a href="/view.php?id=1" title="[closed] Closing scene freezes 3D viewer" class="resolved">0000001</a>, queue = 'com.apple.main-thread', stop reason = step over
    frame #0: 0x00000001014a8818 libqSlicerBaseQTCore.dylib`ctkFactoryPluginItem<qSlicerAbstractCoreModule>::load(this=0x000000013322b2f0) at ctkAbstractPluginFactory.tpp:50
   47     ctkScopedCurrentDir scopedCurrentDir(QFileInfo(this->path()).path());
   48     this->Loader.setFileName(this->path());
   49     bool loaded = this->Loader.load();
-> 50     if (!loaded)
   51       {
   52       this->appendLoadErrorString(this->loadErrorString());
   53       }

running with QT_PLUGINS_DEBUG=1 gives:

Searching path:  "inner-build/lib/Slicer-4.9/qt-loadable-modules/"
 checking file:  "/opt/bld/SlicerJupyter-s5/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"  as a  36qSlicerScriptedLoadableModuleFactory
 checking file:  "/opt/bld/SlicerJupyter-s5/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"  as a  33qSlicerCLIExecutableModuleFactory
 checking file:  "/opt/bld/SlicerJupyter-s5/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"  as a  31qSlicerCLILoadableModuleFactory
 checking file:  "/opt/bld/SlicerJupyter-s5/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"  as a  28qSlicerLoadableModuleFactory
 recognized file:  "/opt/bld/SlicerJupyter-s5/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"  as a  28qSlicerLoadableModuleFactory
Trying... "./inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"
Trying... "./inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.so"
Trying... "./inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.bundle"
Trying... "./inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.dylib"
Trying... "./inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib"
Trying... "./inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.so"
Trying... "./inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.bundle"
Trying... "./inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/Extensions-27273/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/Extensions-27273/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.so"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/Extensions-27273/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.bundle"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/Extensions-27273/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/Extensions-27273/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/Extensions-27273/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.so"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/Extensions-27273/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.bundle"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/Extensions-27273/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.so"
Trying... "/opt/bld/s5nj/Slicer-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.bundle"
Trying... "/opt/bld/s5nj/Slicer-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.so"
Trying... "/opt/bld/s5nj/Slicer-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.bundle"
Trying... "/opt/bld/s5nj/Slicer-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.dylib"
Trying... "/opt/bld/s5nj/CTK-build/CTK-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"
Trying... "/opt/bld/s5nj/CTK-build/CTK-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.so"
Trying... "/opt/bld/s5nj/CTK-build/CTK-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.bundle"
Trying... "/opt/bld/s5nj/CTK-build/CTK-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.dylib"
Trying... "/opt/bld/s5nj/CTK-build/CTK-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib"
Trying... "/opt/bld/s5nj/CTK-build/CTK-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.so"
Trying... "/opt/bld/s5nj/CTK-build/CTK-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.bundle"
Trying... "/opt/bld/s5nj/CTK-build/CTK-build/bin/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.dylib"
Trying... "/opt/sw/Qt/5.9.3/clang_64/plugins/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"
Trying... "/opt/sw/Qt/5.9.3/clang_64/plugins/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.so"
Trying... "/opt/sw/Qt/5.9.3/clang_64/plugins/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.bundle"
Trying... "/opt/sw/Qt/5.9.3/clang_64/plugins/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.dylib"
Trying... "/opt/sw/Qt/5.9.3/clang_64/plugins/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib"
Trying... "/opt/sw/Qt/5.9.3/clang_64/plugins/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.so"
Trying... "/opt/sw/Qt/5.9.3/clang_64/plugins/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.bundle"
Trying... "/opt/sw/Qt/5.9.3/clang_64/plugins/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/MacOS/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/MacOS/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.so"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/MacOS/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.bundle"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/MacOS/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/MacOS/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/MacOS/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.so"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/MacOS/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.bundle"
Trying... "/opt/bld/s5nj/Slicer-build/bin/Slicer.app/Contents/MacOS/inner-build/lib/Slicer-4.9/qt-loadable-modules/liblibqSlicerJupyterKernelModule.dylib.dylib"
"inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib" not found
Attempt to register "JupyterKernel" .................................. [Failed]
  Error(s):
    The shared library was not found.
 file:  "/opt/bld/SlicerJupyter-s5/inner-build/lib/Slicer-4.9/qt-loadable-modules/libqSlicerJupyterKernelModule.dylib"  ignored because moduleName does not match registeredModuleName
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-07-26 13:51 inorton New Issue
2018-07-26 13:51 inorton Status new => assigned
2018-07-26 13:51 inorton Assigned To => jcfr