View Issue Details

IDProjectCategoryView StatusLast Update
0004597Slicer4Module EMSegmentpublic2018-10-16 03:18
ReportershinisterAssigned Topohl 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionwon't fix 
PlatformMacOSmacOS High SierraOS Version10.13.5
Product VersionSlicer 4.8.1 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0004597: Python crash creating user interface for EMSegmenter with Atlas
Description

When starting the "EMSegmenter with Atlas" module, using the "MRI Human Brain Parcellation" task, "Advanced" mode; and going to the final pre-processing next step the Python module crashes with the following output in Python Interactor:

Python 2.7.13 (default, Aug 9 2018, 23:06:55)
[GCC 4.2.1 Compatible Apple LLVM 8.0.0 (clang-800.0.42.1)] on darwin

Status: Idle File already exists in cache - reusing it. Requesting load MRHead from /var/folders/lx/30ztklx91wq6znjsg3tjb7zh0000gn/T/Slicer/RemoteIO/MR-head.nrrd... Load finished [EMSegmentPy 08/11/2018 13:23:46]: Added to List Task: 'CT Hand Bone' File : '/var/folders/lx/30ztklx91wq6znjsg3tjb7zh0000gn/T/Slicer/EMSegmentTaskCopy/CT-Hand-Bone.mrml' [EMSegmentPy 08/11/2018 13:23:46]: Added to List Task: 'MRI Human Brain Full Parcellation' File : '/var/folders/lx/30ztklx91wq6znjsg3tjb7zh0000gn/T/Slicer/EMSegmentTaskCopy/MRI-Human-Brain-Full-Parcellation.mrml' [EMSegmentPy 08/11/2018 13:23:46]: Added to List Task: 'MRI Human Brain Hemisphere' File : '/var/folders/lx/30ztklx91wq6znjsg3tjb7zh0000gn/T/Slicer/EMSegmentTaskCopy/MRI-Human-Brain-Hemisphere.mrml' [EMSegmentPy 08/11/2018 13:23:46]: Added to List Task: 'MRI Human Brain Parcellation' File : '/var/folders/lx/30ztklx91wq6znjsg3tjb7zh0000gn/T/Slicer/EMSegmentTaskCopy/MRI-Human-Brain-Parcellation.mrml' [EMSegmentPy 08/11/2018 13:23:46]: Added to List Task: 'MRI Human Brain' File : '/var/folders/lx/30ztklx91wq6znjsg3tjb7zh0000gn/T/Slicer/EMSegmentTaskCopy/MRI-Human-Brain.mrml' [EMSegmentPy 08/11/2018 13:23:46]: Added to List Task: 'Non Human Primate' File : '/var/folders/lx/30ztklx91wq6znjsg3tjb7zh0000gn/T/Slicer/EMSegmentTaskCopy/Non-Human-Primate.mrml' [EMSegmentPy 08/11/2018 13:23:53]: Attempting to load task 'MRI Human Brain Parcellation' from file '/var/folders/lx/30ztklx91wq6znjsg3tjb7zh0000gn/T/Slicer/EMSegmentTaskCopy/MRI-Human-Brain-Parcellation.mrml' [EMSegmentPy 08/11/2018 13:23:59]: Loading completed. Error executing __tpycl_result = slicer.string() (<type 'exceptions.TypeError'>, TypeError("'module' object is not callable",), <traceback object at 0x11d7f1908>)

...

Traceback (most recent call last):
File "/Applications/Slicer.app/Contents/lib/Slicer-4.9/qt-loadable-modules/Python/EMSegmentWizard/EMSegmentDefineInputChannelsStep.py", line 169, in onExit
if int( returnValue ) != 0:
TypeError: int() argument must be a string or a number, not 'NoneType'

Steps To Reproduce

Errors occurs on user data and downloadable MRHead sample data (both "Advanced" and "Simple" mode). Error occurs on 4.8.1 and Nightly.

TagsNo tags attached.

Relationships

has duplicate 0004427 resolvedpohl Python crash creating user interface for EMSegmenter with Atlas 

Activities

jcfr

jcfr

2018-10-16 03:18

administrator   ~0016136

Resolving this issue since EMSegment is not part of Slicer anymore.
See http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=27470


ENH: Disable TCL Bridge by default See 0004625

See https://issues.slicer.org/view.php?id=4625
and https://discourse.slicer.org/t/should-we-do-something-about-em-segmenter/4382

Disabling TCL since it is only used by EMSegment, which is
non-functional. Disabling the TCL option will also disable
EMSegment.

Issue History

Date Modified Username Field Change
2018-08-11 13:30 shinister New Issue
2018-08-11 13:30 shinister Status new => assigned
2018-08-11 13:30 shinister Assigned To => pohl
2018-08-11 13:30 shinister Description Updated View Revisions
2018-08-11 13:31 shinister Description Updated View Revisions
2018-08-11 13:33 shinister Description Updated View Revisions
2018-08-11 13:33 shinister Steps to Reproduce Updated View Revisions
2018-10-16 03:17 jcfr Relationship added has duplicate 0004427
2018-10-16 03:18 jcfr Status assigned => resolved
2018-10-16 03:18 jcfr Resolution open => won't fix
2018-10-16 03:18 jcfr Fixed in Version => Slicer 4.9.0
2018-10-16 03:18 jcfr Note Added: 0016136