View Issue Details

IDProjectCategoryView StatusLast Update
0000046Slicer3Base Codepublic2007-04-02 06:49
ReporterkeilhackAssigned Toalexy 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Summary0000046: vtkMRMLScene::GetNextNodeByClass Segementation faults
Description

"if( !this || !this->CurrentScene )" should be "if ( !this && !this->CurrentScene )"

Actually if 'this' is not initialized it will check both statements and throws an segfault error because of accessing CurrentScene which is not available.
I'm not sure though, if this is how it should work on that place.

TagsNo tags attached.

Activities

pieper

pieper

2007-03-27 09:47

administrator   ~0000068

Did this actually crash for you? The logic actually looks correct to me - thta is if 'this' is null, then !this will be true, so the conditional will be true and the method will return NULL.

Issue History

Date Modified Username Field Change
2007-03-05 04:50 keilhack New Issue
2007-03-27 09:47 pieper Note Added: 0000068
2007-03-27 09:47 pieper Assigned To => alexy
2007-03-27 09:47 pieper Status new => acknowledged
2007-04-02 06:49 pieper Status acknowledged => closed
2007-04-02 06:49 pieper Resolution open => unable to reproduce