View Issue Details

IDProjectCategoryView StatusLast Update
0004609Slicer4Module VolumeRenderingpublic2018-09-19 00:23
ReporterlassoanAssigned Toallison.vacanti 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSlicer 4.9.0 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0004609: VTK OpenGL2 Backend: ROI widget sides are completely opaque if depth peeling is enabled
Description

With latest nightly version of Slicer with depth peeling enabled, it is very difficult to set ROI widget, because dragged side of the widget becomes completely opaque and I cannot see anything of what is being clipped.

TagsNo tags attached.

Activities

lassoan

lassoan

2018-09-13 11:27

developer   ~0016005

Depth peeling disabled (correct, semi-transparent display):



lassoan

lassoan

2018-09-13 11:28

developer   ~0016006

Depth peeling enabled (incorrect, non-transparent display):



jcfr

jcfr

2018-09-13 12:23

administrator   ~0016015

I am also able to reproduce this on Ubuntu using my Nvidia Quadro M2000M

allison.vacanti

allison.vacanti

2018-09-18 16:59

developer   ~0016028

Looks like the box representation wasn't setting some properties on its child actors that are required for depth peeling to work. https://gitlab.kitware.com/vtk/vtk/merge_requests/4683 should fix this.

lassoan

lassoan

2018-09-19 00:23

developer   ~0016030

Thanks a lot Allie, your solution worked!

Box widget representation had modified clone in Slicer (vtkAnnotationROIRepresentation), so your changes had to be applied to this class, too (https://github.com/Slicer/Slicer/commit/4fe556901a5e803a45b7e5fe81759d8f8b98eaa4). This fixed the ROI widget's opacity with depth peeling enabled.

Issue History

Date Modified Username Field Change
2018-09-13 11:26 lassoan New Issue
2018-09-13 11:26 lassoan Status new => assigned
2018-09-13 11:26 lassoan Assigned To => allison.vacanti
2018-09-13 11:27 lassoan File Added: depth-peeling-disabled.png
2018-09-13 11:27 lassoan Note Added: 0016005
2018-09-13 11:28 lassoan File Added: depth-peeling-enabled.png
2018-09-13 11:28 lassoan Note Added: 0016006
2018-09-13 11:57 jcfr Summary ROI widget sides are completely opaque if depth peeling is enabled => VTK OpenGL2 Backend: ROI widget sides are completely opaque if depth peeling is enabled
2018-09-13 12:23 jcfr Note Added: 0016015
2018-09-13 14:17 lassoan Description Updated View Revisions
2018-09-18 16:59 allison.vacanti Note Added: 0016028
2018-09-19 00:23 lassoan Note Added: 0016030
2018-09-19 00:23 lassoan Status assigned => resolved
2018-09-19 00:23 lassoan Resolution open => fixed
2018-09-19 00:23 lassoan Fixed in Version => Slicer 4.9.0