View Issue Details

IDProjectCategoryView StatusLast Update
0004619Slicer4Extension: (Any extensions)public2018-10-04 21:31
ReportertorquilAssigned Tolassoan 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS VersionSid
Product Version 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0004619: Hardcoded video length limit of 30 s is too low in ScreenCapture.py
Description

In ScreenCapture.py, there seems to be a hardcoded limit on video length which is set to 30s. Line 224:

self.videoLengthSliderWidget.maximum = 30

I'm working on fluoroscopyvideos, and some of them are longer than 30s, so I had to change to 60 in the Slicer source to accomodate this. 30 s seems rather low. Perhaps a limit is needed for reasons I do not know about, but perhaps the limit could be increased, e.g. to 600?

Additional Information

3d Slicer Git Master as of today, built from source on Debian Sid Linux with GCC 8.2.0.

TagsNo tags attached.

Activities

Issue History

Date Modified Username Field Change
2018-09-21 05:46 torquil New Issue
2018-10-04 21:31 lassoan Assigned To => lassoan
2018-10-04 21:31 lassoan Status new => resolved
2018-10-04 21:31 lassoan Resolution open => fixed
2018-10-04 21:31 lassoan Fixed in Version => Slicer 4.9.0
2018-10-04 21:31 lassoan Note Added: 0016077