View Issue Details

IDProjectCategoryView StatusLast Update
0004622Slicer4Module Editorpublic2018-12-12 14:30
ReporterCDonatelliAssigned Topieper 
PriorityhighSeveritymajorReproducibilitysometimes
Status resolvedResolutionno change required 
Product VersionSlicer 4.8.1 
Target VersionFixed in Version 
Summary0004622: Editor will not allow Remove Island Effect
Description

I cannot use the modify island effect to edit my segmentation. I've tried different files as well as re-starting my computer several times.

Steps To Reproduce

Open nrrd file
use threshold effect to highlight everything in a set density range
Use Identify Island effect to identify islands with a min size of 100
Click "modify island" effect
Click island you wish to modify -> error below

Additional Information

[DEBUG][Qt] 07.10.2018 12:59:39 [] (unknown:0) - Session start time .......: 2018-10-07 12:59:39
[DEBUG][Qt] 07.10.2018 12:59:39 [] (unknown:0) - Slicer version ...........: 4.8.1 (revision 26813) win-amd64 - installed
[DEBUG][Qt] 07.10.2018 12:59:39 [] (unknown:0) - Operating system .........: Windows / Personal / (Build 9200) - 64-bit
[DEBUG][Qt] 07.10.2018 12:59:39 [] (unknown:0) - Memory ...................: 65437 MB physical, 75165 MB virtual
[DEBUG][Qt] 07.10.2018 12:59:39 [] (unknown:0) - CPU ......................: GenuineIntel , 8 cores, 16 logical processors
[DEBUG][Qt] 07.10.2018 12:59:39 [] (unknown:0) - Developer mode enabled ...: no
[DEBUG][Qt] 07.10.2018 12:59:39 [] (unknown:0) - Prefer executable CLI ....: yes
[DEBUG][Qt] 07.10.2018 12:59:39 [] (unknown:0) - Additional module paths ..: C:/Users/Biomechanics User/AppData/Roaming/NA-MIC/Extensions-26813/FastGrowCutEffect/lib/Slicer-4.8/qt-loadable-modules, C:/Users/Biomechanics User/AppData/Roaming/NA-MIC/Extensions-26813/FastGrowCutEffect/lib/Slicer-4.8/qt-scripted-modules
[DEBUG][Python] 07.10.2018 12:59:51 [Python] (C:\Program Files\Slicer 4.8.1\lib\Python\Lib\site-packages\git\cmd.py:719) - Popen(%s, cwd=%s, universal_newlines=%s, shell=%s)
[DEBUG][Python] 07.10.2018 12:59:53 [Python] (C:\Program Files\Slicer 4.8.1\lib\Python\Lib\site-packages\git\cmd.py:719) - Popen(%s, cwd=%s, universal_newlines=%s, shell=%s)
[DEBUG][Python] 07.10.2018 13:00:01 [Python] (C:\Program Files\Slicer 4.8.1\lib\Slicer-4.8\qt-scripted-modules\SubjectHierarchyPlugins\AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: Annotations
[DEBUG][Python] 07.10.2018 13:00:02 [Python] (C:\Program Files\Slicer 4.8.1\lib\Slicer-4.8\qt-scripted-modules\SubjectHierarchyPlugins\AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentEditor
[DEBUG][Python] 07.10.2018 13:00:02 [Python] (C:\Program Files\Slicer 4.8.1\lib\Slicer-4.8\qt-scripted-modules\SubjectHierarchyPlugins\AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentStatistics
[DEBUG][Qt] 07.10.2018 12:59:41 [] (unknown:0) - Number of registered modules: 137
[DEBUG][Qt] 07.10.2018 12:59:57 [] (unknown:0) - Number of instantiated modules: 137
[DEBUG][Qt] 07.10.2018 13:00:03 [] (unknown:0) - Number of loaded modules: 137
[DEBUG][Qt] 07.10.2018 13:00:03 [] (unknown:0) - Switch to module: "Welcome"
[INFO][VTK] 07.10.2018 13:02:52 [vtkMRMLVolumeArchetypeStorageNode (000002991099E750)] (D:\D\P\Slicer-481\Libs\MRML\Core\vtkMRMLVolumeArchetypeStorageNode.cxx:465) - Loaded volume from file: C:/Users/Biomechanics User/Desktop/Cassandra/Star Nrrd/Stars2_triangle.nrrd. Dimensions: 504x2204x2954. Number of components: 1. Pixel type: unsigned char.
[DEBUG][Qt] 07.10.2018 13:02:52 [] (unknown:0) - "Volume" Reader has successfully read the file "C:/Users/Biomechanics User/Desktop/Cassandra/Star Nrrd/Stars2_triangle.nrrd" "[41.16s]"
[DEBUG][Qt] 07.10.2018 13:03:16 [] (unknown:0) - Switch to module: "Editor"
[INFO][Stream] 07.10.2018 13:06:35 [] (unknown:0) - 3880 islands created (44908 ignored)
[CRITICAL][Qt] 07.10.2018 13:07:35 [] (unknown:0) - "Slicer has caught an internal error.

You may be able to continue from this point, but results are undefined.

Suggested action is to save your work and restart.

If you have a repeatable sequence of steps that causes this message, please report the issue following instructions available at http://slicer.org

The message detail is:

Exception thrown in event: bad allocation"
[CRITICAL][Qt] 07.10.2018 13:07:38 [] (unknown:0) - "Slicer has caught an internal error.

You may be able to continue from this point, but results are undefined.

Suggested action is to save your work and restart.

If you have a repeatable sequence of steps that causes this message, please report the issue following instructions available at http://slicer.org

The message detail is:

Exception thrown in event: bad allocation"

TagsNo tags attached.

Activities

CDonatelli

CDonatelli

2018-10-07 16:17

reporter  

Slicer_26813_20181007_125939.log (4,022 bytes)
pieper

pieper

2018-10-08 15:29

administrator   ~0016089

Hi -

When you get a "bad allocation" message it means you've run out of memory. You can either get more memory (buy ram or increase virtual memory) or you can use the Crop Volume module to reduce the size of the problem to fit in existing memory.

Also, the Editor module has been upgraded in recent Slicer's as the Segment Editor module, with all the old features plus a bunch more. We won't be maintaining the old Editor module any more.

-Steve

CDonatelli

CDonatelli

2018-10-09 14:30

reporter   ~0016103

Hello Steve,

Thanks for the information. I've been using a pretty powerful computer and the task manager says slicer is only using 65% of the memory when trying to perform this operation. That is a lot though, so I'll try to cut it down in some way. I do like the Segment Editor module, but, unfortunately, I need to be able to save my segmented morphology as a .nrrd file so that I can re-slice it in image J for later analysis. I haven't been able to find a way to save the segments created in Segment Editor as anything but an STL or surface model, so I loose all the density data. Do you happen to know a way to save segments created in Segment Editor as a nrrd or image stack?

Thanks so much!

pieper

pieper

2018-10-09 14:35

administrator   ~0016104

Hi -

At the bottom of the bottom of the Segmentations module you can export the segmentation as a labelmap volume that you can store as a regular nrrd file.

Not sure how the memory management may be better or worse in the Segment Editor so you may or may not still need to crop.

Best,
Steve



export.png (154,779 bytes)
export.png (154,779 bytes)
CDonatelli

CDonatelli

2018-10-10 13:41

reporter   ~0016107

That's great, thanks!

Looks like I need a memory upgrade for my computer after all.

Thanks again!

Issue History

Date Modified Username Field Change
2018-10-07 16:17 CDonatelli New Issue
2018-10-07 16:17 CDonatelli Status new => assigned
2018-10-07 16:17 CDonatelli Assigned To => pieper
2018-10-07 16:17 CDonatelli File Added: Slicer_26813_20181007_125939.log
2018-10-08 15:29 pieper Status assigned => feedback
2018-10-08 15:29 pieper Note Added: 0016089
2018-10-09 14:30 CDonatelli Note Added: 0016103
2018-10-09 14:30 CDonatelli Status feedback => assigned
2018-10-09 14:35 pieper File Added: export.png
2018-10-09 14:35 pieper Note Added: 0016104
2018-10-10 13:41 CDonatelli Note Added: 0016107
2018-12-12 14:30 lassoan Status assigned => resolved
2018-12-12 14:30 lassoan Resolution open => no change required