View Issue Details

IDProjectCategoryView StatusLast Update
0004628Slicer4Module Markupspublic2018-10-17 13:24
ReporterjamesobutlerAssigned Tojcfr 
PriorityurgentSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows 10 HomeOS Version1809
Product Version 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0004628: Unable to move fiducial position with cursor
Description

I'm unable to move a placed fiducial with the cursor. I'm only able to move it some arbitrary small distance (less than the voxel dimension for the sample data volume). The fiducial isn't locked. When it is locked, it doesn't move at all. No errors are indicated in the log file.

Steps To Reproduce

Using Slicer 4.9.0-2018-10-09

  1. Open MR-head.nrrd from sample data.
  2. Place a fiducial in slice viewer
  3. Click and hold on fiducial to attempt to move.
TagsNo tags attached.

Relationships

related to 0004634 assignedpieper Most fiducials not selectable in LandmarkRegistration with latest VTK 

Activities

jamesobutler

jamesobutler

2018-10-11 13:30

reporter  

Slicer_27464_20181011_132134.log (4,211 bytes)
pieper

pieper

2018-10-11 14:13

administrator   ~0016110

I confirm this occurs on linux, mac, and windows with the current build.

lassoan

lassoan

2018-10-11 15:41

developer   ~0016112

I can reproduce it, too.

4.9.0-2018-09-30 (revision 27437) win-amd64 => works well
4.9.0-2018-10-03 (revision 27449) win-amd64 => broken

There was a VTK update between these versions and nothing related to markups, so the regression is caused by VTK changes. I don't think I'll have time to investigate this any further today.

pieper

pieper

2018-10-11 22:07

administrator   ~0016113

I didn't try any tests, but these widget changes seem like they could lead to this sort of issue:

https://github.com/Kitware/VTK/commit/92e2c1dc86cdeff3902d6efe7458f3eccad6c4fa

pieper

pieper

2018-10-11 22:14

administrator   ~0016114

As expected, the issue doesn't happen on at Qt4 build which uses an older version of VTK.

jcfr

jcfr

2018-10-13 02:50

administrator   ~0016115

This regression was introduced by https://gitlab.kitware.com/vtk/vtk/merge_requests/4701

jcfr

jcfr

2018-10-13 03:05

administrator   ~0016116

Fixed in r27468
See http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=27468

pieper

pieper

2018-10-13 15:00

administrator   ~0016122

Tested on a linux build and worked well - thanks for the quick fix!

sankhesh

sankhesh

2018-10-17 13:24

developer   ~0016165

The fix is pushed here: https://gitlab.kitware.com/vtk/vtk/merge_requests/4794

Issue History

Date Modified Username Field Change
2018-10-11 13:30 jamesobutler New Issue
2018-10-11 13:30 jamesobutler Status new => assigned
2018-10-11 13:30 jamesobutler Assigned To => nicole
2018-10-11 13:30 jamesobutler File Added: Slicer_27464_20181011_132134.log
2018-10-11 14:12 pieper Assigned To nicole =>
2018-10-11 14:13 pieper Assigned To => pieper
2018-10-11 14:13 pieper Status assigned => confirmed
2018-10-11 14:13 pieper Note Added: 0016110
2018-10-11 14:15 pieper Priority normal => urgent
2018-10-11 14:15 pieper Severity major => block
2018-10-11 14:15 pieper Reproducibility have not tried => always
2018-10-11 14:15 pieper Target Version => Slicer 4.9.0
2018-10-11 14:15 pieper Steps to Reproduce Updated View Revisions
2018-10-11 15:41 lassoan Note Added: 0016112
2018-10-11 22:07 pieper Note Added: 0016113
2018-10-11 22:14 pieper Note Added: 0016114
2018-10-13 02:50 jcfr Note Added: 0016115
2018-10-13 03:05 jcfr Assigned To pieper => jcfr
2018-10-13 03:05 jcfr Status confirmed => resolved
2018-10-13 03:05 jcfr Resolution open => fixed
2018-10-13 03:05 jcfr Fixed in Version => Slicer 4.9.0
2018-10-13 03:05 jcfr Note Added: 0016116
2018-10-13 15:00 pieper Status resolved => closed
2018-10-13 15:00 pieper Note Added: 0016122
2018-10-15 18:33 jcfr Relationship added related to 0004634
2018-10-17 13:24 sankhesh Note Added: 0016165